I have a 02 cadillac runs perfectly out of no where i have no speed only does 3 or 4 mph

Asked by Dec 12, 2015 at 02:12 PM about the 2002 Cadillac DeVille Base

Question type: Maintenance & Repair

2 Answers

25,195

Sounds like you are in limp mode. A common cause is a throttle position sensor failed. The car computer can't determine where the throttle is so you get limp mode. Inspect & clean the throttle body and pay attention to the TPS plug/contacts for corrosion, try re-seating it.

1 of 1 people found this helpful.

Il tryin that thanks

Your Answer

Add photo

Related Questions

Search Cadillac DeVille Questions

Cadillac DeVille Experts

#1 kikero
kikero
Reputation 2,160
#2 Js08016
Js08016
Reputation 1,860
#3 Cynthiasmith
Cynthiasmith
Reputation 1,600
View All

Related Models For Sale

Used Cadillac CTS
223 Great Deals out of 10,320 listings starting at $1,595
Used Cadillac Seville
358 listings starting at $2,500
Used Lincoln Town Car
38 Great Deals out of 1,812 listings starting at $1,495
Used Chevrolet Impala
556 Great Deals out of 35,581 listings starting at $899
Used Cadillac Escalade
199 Great Deals out of 10,896 listings starting at $2,500
Used Ford Mustang
710 Great Deals out of 44,429 listings starting at $1,500
Used Chevrolet Corvette
223 Great Deals out of 22,144 listings starting at $3,750
Used Mercedes-Benz S-Class
169 Great Deals out of 6,264 listings starting at $2,000
Used Chevrolet Camaro
357 Great Deals out of 31,259 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.