hi there why is my 06 sts 3.6 running rough

Asked by Jun 21, 2013 at 12:12 AM about the 2006 Cadillac STS V6

Question type: Maintenance & Repair

it starts up cold runs great after 3-5 mins it starts running rough and missing but if i
accelerate or drive it its fine? any help would be great

2 Answers

5

check the motor mounts i have had to replace both of mine in the past 3-4 months.

you need to check the oil pan for deposits, blocking the pickup screen.

Your Answer

Add photo

Related Questions

Search Cadillac STS Questions

Cadillac STS Experts

#1 tenspeed
tenspeed
Reputation 460
#2 Tom Demyan
Tom Demyan
Reputation 130
#3 Js08016
Js08016
Reputation 120
View All

Related Models For Sale

Used Cadillac CTS
186 Great Deals out of 10,513 listings starting at $1,500
Used Cadillac DTS
57 Great Deals out of 1,612 listings starting at $1,575
Used Cadillac SRX
264 Great Deals out of 8,663 listings starting at $2,788
Used Cadillac STS-V
42 listings starting at $9,900
Used Chrysler 300
400 Great Deals out of 19,199 listings starting at $850
Used Cadillac CTS-V
9 Great Deals out of 475 listings starting at $9,995
Used Cadillac Escalade
195 Great Deals out of 10,972 listings starting at $3,200
Used Dodge Charger
454 Great Deals out of 29,324 listings starting at $2,300
Used Cadillac DeVille
4 Great Deals out of 1,627 listings starting at $1,988
Used BMW 7 Series
164 Great Deals out of 5,957 listings starting at $2,999
Used Chevrolet Impala
590 Great Deals out of 34,064 listings starting at $899

Used Cars For Sale

2009 Cadillac STS V6 For Sale
17 listings starting at $7,495
2008 Cadillac STS V6 For Sale
72 listings starting at $5,590

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.