hi there why is my 06 sts 3.6 running rough

Asked by Jun 21, 2013 at 12:12 AM about the 2006 Cadillac STS V6

Question type: Maintenance & Repair

it starts up cold runs great after 3-5 mins it starts running rough and missing but if i
accelerate or drive it its fine? any help would be great

2 Answers

5

check the motor mounts i have had to replace both of mine in the past 3-4 months.

you need to check the oil pan for deposits, blocking the pickup screen.

Your Answer

Cadillac STS Experts

  • #1
    tenspeed
    Reputation
    490
  • #2
    Js08016
    Reputation
    130
  • #2
    Tom Demyan
    Reputation
    130
View All

Related Models For Sale

Used Cadillac CTS
274 Great Deals out of 9,980 listings starting at $1,395
Used Cadillac DTS
57 Great Deals out of 1,563 listings starting at $2,975
Used Cadillac SRX
396 Great Deals out of 9,401 listings starting at $1,759
Used Cadillac STS-V
28 listings starting at $9,888
Used Chrysler 300
320 Great Deals out of 17,895 listings starting at $1,295
Used Cadillac CTS-V
6 Great Deals out of 586 listings starting at $9,900
Used Cadillac Escalade
222 Great Deals out of 11,244 listings starting at $2,000
Used Dodge Charger
441 Great Deals out of 27,995 listings starting at $1,979
Used Chevrolet Impala
515 Great Deals out of 34,210 listings starting at $950
Used Cadillac DeVille
4 Great Deals out of 1,634 listings starting at $1,995

Used Cars For Sale

2009 Cadillac STS V6 For Sale
23 listings starting at $5,995
2008 Cadillac STS V6 For Sale
4 Great Deals out of 85 listings starting at $5,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.