Transmission shifting problems

80

Asked by May 06, 2015 at 12:10 PM about the 2008 Chevrolet TrailBlazer LT1 4WD

Question type: Maintenance & Repair

When I take off in drive the seems to hang between gears and engine will race. I can
slow down and manually shift into the right gear and it will start shifting properly. This this
does not happen every time I start off from stop.

24 Answers

98,385

Sounds like the solenoids are getting sticky inside the tranny, you can try servicing it, putting a quart of TransX and then fill to specs and drive as you normally do, this will help cleaning the solenoids, if it is going to work it will in the next day or two, if things don't change then you will have to replace the solenoids. Eventually you will have to replace them.

13 of 13 people found this helpful.
80

Thanks for the info took car to transmission shop. It was checked out and turned out to be selenoids.

8 of 8 people found this helpful.
98,385

Glad you got right on this and fixed it, so many just want to get by as long as they can.

2 of 2 people found this helpful.
200

needs some help by any chance do u know why my tranny didnt work after i change both solenoids

12 of 12 people found this helpful.
98,385

H, did you have codes for the solenoids? Or was it trans control codes?

6 of 6 people found this helpful.
200

yea i forgot to erase codes thats why it wasnt working but now it is ..but i have had this problem for a month see if u can help me out same 2002 trailblazer ltz 4wd 4.2 6 inline plugs my check gages light turns off and on wen ever it feels like and wen that happens forces my engine fan blows hard my temp gage goes from 100° to 260° but my car is not overheating every morning wen i turn my blazer on temp gage goes rapidly to 269° even if my engine is still cold i already changed water pump thermostat temp sensor belt and its steel reads code p0117 engine coolant circiut low input i dont know wat to do anymore also wen the check gage comes on it reads engine coolant hot idle engine even if the engine is still cold i could just turn key on and that happens.. driving me crazy already need a good answer and help please and wen the check gages light comes on it doesn't read the five volts is suppose to it reads below 2volts and wen lights off it reads the five volts let me know if i can do something to fix it on my own please and thanks for responding to my questions

2 of 2 people found this helpful.
98,385

What you are describing sounds like an intermittent ground problem, unfortunately there are a mess of grounds on this rig, both inside and under the hood, if you want to attempt this I would advise you to get a good shop manual with wiring diagrams and component locator, then grab your wire brush, emery paper and start cleaning the grounds. HTH

3 of 3 people found this helpful.
200

wat is hth and thanks for ur answers appropriate it alot ill try that but would it efect if i put a ground wire directly to the black ground wire on the sensor just to see if anything changes and so do u think the pcm modual or computer i guess is the same thing but could it be damaged

1 of 1 people found this helpful.
98,385

HTH is hope this helps. You have to be very careful running ground wires, you can do that but make sure you only use the main grounding mounts, not just a sensor ground wire, you can also run separate ground to each of the points you find from a reliable grounding point, but make sure you have a ground and not a sensing wire or power feed, 12 or 5 volts, or it will cause expensive damage. You might also check the contacts on the back of the instrument cluster and the cluster grounds. I know this sounds involved but it really isn't if you have the connection points in the shop manual it reduces time involved and you can trace out each circuit.

1 of 1 people found this helpful.
200

ok thanks very much for ur help ill try and run only one ground wire from the sensor to a grounding point and i will definitely not try to power feed to any sensor that could effect my vehicle just one ground i will run thanks again and have a wonderful evening

1 of 1 people found this helpful.
870

Hi i have 2006 trailblazer when i put in drive it shifts through first 2 gears and when it goes to 3rd it slips and idles up. I have to put it in 2nd to go hoping i dont need transmission. Any help is appreciated thanks

87 of 87 people found this helpful.
250

i have a2002 ltz and it will not shift from 1st to second without letting off the gas. The vehicle speed sensor was changed. Any and all advice is apprecitaed. tyia

25 of 25 people found this helpful.
90

I have a 1995 s10 blazer and it would appear that the same problem has been apparent since this blazer if not before, and up and to the current models and I cannot believe they have not corrected this yet!!! , or even at least to all of your helpful comments Up an 'till the 2006 model yr. Scott~LittleRiverSC.

1 of 1 people found this helpful.
90

Like I said above, I have a 1995 s10 4x4 4dr blazer w/212k on it. I was told to put Lucas in the tranny, so that's what I did with NO resolution to the shifting problems!! I only drive it to the grocery store once a month, but I either need a quick short term fix so I can sell it or I need to resurrect it for another 30-50k. Any help would be greatly appreciated !! Is this blazer even worth keeping or should I just try to sell it as is? Thanks again for your help Scott~LittleRiverSC. Eightsixzero nineeighttwo seventhreefourtwo

7 of 7 people found this helpful.
70

hi i have an 07 trailblazer ss when i put it in reverse it doesnt move i can put it in drive and it goes but no reverse any ideas on how to fix thanks

7 of 7 people found this helpful.
90

Sorry Anthony, I haven't received any answers to my transmission issues either. Now my blazer is dead in the driveway. Best of luck to you. Scott

1 of 1 people found this helpful.
70

2007 Trailblazer Not shifting in to the 3rd gear... (slipping) Lucas mechanic in a bottle did dick. Hope it's an easy fix because I bought am older car to safe money. Shit.

4 of 4 people found this helpful.
98,385

If it is slipping it most likely needs overhauled, if the trans fluid is dark and smells burnt that is a sure sign of a trans in need of a overhaul.

2 of 2 people found this helpful.
70

Which is expensive right? ... It actually was most our of fluid yesterday and I dumped in a bottle if Lucas and a quart of transmission fluid. I have driven 10-15 miles since I did that but only Reverse, 1st, 2nd work like it is supposed to. In drive it takes off normal but once you get to 50mph or so rather than shifting down it revs up. It is over full now by the way...

3 of 3 people found this helpful.
98,385

Yep, between 800 and 1000 bucks in my area, I have heard of some people that have drove through that they have paid as high as 2 grand, I guess it all depends on your area.

3 of 3 people found this helpful.
50

Anthony, your transmission likely blew out it's sun gear housing. This is a common problem on the 4l60E transmissions. If the housing did blow out, you will also not have second gear, resulting in a hard shift from first to third.

5 of 5 people found this helpful.

HI I HAVE TRAILBLAZER 2008 I SHIFT GEAR IN D NO START DRIVE ONLY DRIVE R AND DRIVE MANUAL 1 2 I CHICK ON COMPUTER ERROR CODE P0717 INPUT SPEED SENSOR CIRCUIT LOW VOLTAGE

10

I have a 2003 chevy trailblazer if I I put it in the drive it don't move but if I put it in 1 2 or r it moves what is it

1 of 1 people found this helpful.

I need help with my 01 chevy blazer 4x4 there is a leak in the tranny someware up front and possibly the mid section of the tranny ot at least thats ware the leaks are commin thru on the tranny cover

Your Answer

TrailBlazer

Looking for a Used TrailBlazer in your area?

CarGurus has 4,728 nationwide TrailBlazer listings starting at $1,000.

ZIP:

Chevrolet TrailBlazer Experts

  • #1
    bigdogracer
    Reputation
    870
  • #2
    Tom Demyan
    Reputation
    850
  • #3
    tennisshoes
    Reputation
    660
View All

Related Models For Sale

Used Chevrolet Tahoe
626 Great Deals out of 36,240 listings starting at $1,800
Used Jeep Grand Cherokee
923 Great Deals out of 70,927 listings starting at $995
Used GMC Envoy
57 Great Deals out of 2,186 listings starting at $1,999
Used Chevrolet Silverado 1500
2,149 Great Deals out of 183,298 listings starting at $1,693
Used Ford Explorer
814 Great Deals out of 62,844 listings starting at $1,495
Used Chevrolet Impala
590 Great Deals out of 34,660 listings starting at $1,000
Used Dodge Charger
468 Great Deals out of 27,625 listings starting at $1,650
Used Chevrolet Equinox
1,007 Great Deals out of 81,404 listings starting at $999
Used Dodge Durango
290 Great Deals out of 20,261 listings starting at $999
Used GMC Yukon
409 Great Deals out of 20,824 listings starting at $1,495
Used Ford F-150
2,234 Great Deals out of 181,370 listings starting at $1,500

Used Cars For Sale

2009 Chevrolet TrailBlazer LT1 4WD For Sale
3 Great Deals out of 54 listings starting at $3,695
2008 Chevrolet TrailBlazer LT1 4WD For Sale
6 Great Deals out of 195 listings starting at $3,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.