Transmission shifting problems

50

Asked by May 06, 2015 at 12:10 PM about the 2008 Chevrolet TrailBlazer LT1 4WD

Question type: Maintenance & Repair

When I take off in drive the seems to hang between gears and engine will race. I can
slow down and manually shift into the right gear and it will start shifting properly. This this
does not happen every time I start off from stop.

21 Answers

77,735

Sounds like the solenoids are getting sticky inside the tranny, you can try servicing it, putting a quart of TransX and then fill to specs and drive as you normally do, this will help cleaning the solenoids, if it is going to work it will in the next day or two, if things don't change then you will have to replace the solenoids. Eventually you will have to replace them.

9 out of 9 people think this is helpful.
50

Thanks for the info took car to transmission shop. It was checked out and turned out to be selenoids.

5 out of 5 people think this is helpful.
77,735

Glad you got right on this and fixed it, so many just want to get by as long as they can.

1 out of 1 people think this is helpful.
120

needs some help by any chance do u know why my tranny didnt work after i change both solenoids

7 out of 7 people think this is helpful.
77,735

H, did you have codes for the solenoids? Or was it trans control codes?

4 out of 4 people think this is helpful.
120

yea i forgot to erase codes thats why it wasnt working but now it is ..but i have had this problem for a month see if u can help me out same 2002 trailblazer ltz 4wd 4.2 6 inline plugs my check gages light turns off and on wen ever it feels like and wen that happens forces my engine fan blows hard my temp gage goes from 100° to 260° but my car is not overheating every morning wen i turn my blazer on temp gage goes rapidly to 269° even if my engine is still cold i already changed water pump thermostat temp sensor belt and its steel reads code p0117 engine coolant circiut low input i dont know wat to do anymore also wen the check gage comes on it reads engine coolant hot idle engine even if the engine is still cold i could just turn key on and that happens.. driving me crazy already need a good answer and help please and wen the check gages light comes on it doesn't read the five volts is suppose to it reads below 2volts and wen lights off it reads the five volts let me know if i can do something to fix it on my own please and thanks for responding to my questions

1 out of 1 people think this is helpful.
77,735

What you are describing sounds like an intermittent ground problem, unfortunately there are a mess of grounds on this rig, both inside and under the hood, if you want to attempt this I would advise you to get a good shop manual with wiring diagrams and component locator, then grab your wire brush, emery paper and start cleaning the grounds. HTH

3 out of 3 people think this is helpful.
120

wat is hth and thanks for ur answers appropriate it alot ill try that but would it efect if i put a ground wire directly to the black ground wire on the sensor just to see if anything changes and so do u think the pcm modual or computer i guess is the same thing but could it be damaged

1 out of 1 people think this is helpful.
77,735

HTH is hope this helps. You have to be very careful running ground wires, you can do that but make sure you only use the main grounding mounts, not just a sensor ground wire, you can also run separate ground to each of the points you find from a reliable grounding point, but make sure you have a ground and not a sensing wire or power feed, 12 or 5 volts, or it will cause expensive damage. You might also check the contacts on the back of the instrument cluster and the cluster grounds. I know this sounds involved but it really isn't if you have the connection points in the shop manual it reduces time involved and you can trace out each circuit.

1 out of 1 people think this is helpful.
120

ok thanks very much for ur help ill try and run only one ground wire from the sensor to a grounding point and i will definitely not try to power feed to any sensor that could effect my vehicle just one ground i will run thanks again and have a wonderful evening

1 out of 1 people think this is helpful.
520

Hi i have 2006 trailblazer when i put in drive it shifts through first 2 gears and when it goes to 3rd it slips and idles up. I have to put it in 2nd to go hoping i dont need transmission. Any help is appreciated thanks

52 out of 52 people think this is helpful.
170

i have a2002 ltz and it will not shift from 1st to second without letting off the gas. The vehicle speed sensor was changed. Any and all advice is apprecitaed. tyia

17 out of 17 people think this is helpful.
50

I have a 1995 s10 blazer and it would appear that the same problem has been apparent since this blazer if not before, and up and to the current models and I cannot believe they have not corrected this yet!!! , or even at least to all of your helpful comments Up an 'till the 2006 model yr. Scott~LittleRiverSC.

1 out of 1 people think this is helpful.
50

Like I said above, I have a 1995 s10 4x4 4dr blazer w/212k on it. I was told to put Lucas in the tranny, so that's what I did with NO resolution to the shifting problems!! I only drive it to the grocery store once a month, but I either need a quick short term fix so I can sell it or I need to resurrect it for another 30-50k. Any help would be greatly appreciated !! Is this blazer even worth keeping or should I just try to sell it as is? Thanks again for your help Scott~LittleRiverSC. Eightsixzero nineeighttwo seventhreefourtwo

4 out of 4 people think this is helpful.
10

hi i have an 07 trailblazer ss when i put it in reverse it doesnt move i can put it in drive and it goes but no reverse any ideas on how to fix thanks

1 out of 1 people think this is helpful.
50

Sorry Anthony, I haven't received any answers to my transmission issues either. Now my blazer is dead in the driveway. Best of luck to you. Scott

2007 Trailblazer Not shifting in to the 3rd gear... (slipping) Lucas mechanic in a bottle did dick. Hope it's an easy fix because I bought am older car to safe money. Shit.

77,735

If it is slipping it most likely needs overhauled, if the trans fluid is dark and smells burnt that is a sure sign of a trans in need of a overhaul.

Which is expensive right? ... It actually was most our of fluid yesterday and I dumped in a bottle if Lucas and a quart of transmission fluid. I have driven 10-15 miles since I did that but only Reverse, 1st, 2nd work like it is supposed to. In drive it takes off normal but once you get to 50mph or so rather than shifting down it revs up. It is over full now by the way...

77,735

Yep, between 800 and 1000 bucks in my area, I have heard of some people that have drove through that they have paid as high as 2 grand, I guess it all depends on your area.

Anthony, your transmission likely blew out it's sun gear housing. This is a common problem on the 4l60E transmissions. If the housing did blow out, you will also not have second gear, resulting in a hard shift from first to third.

Your Answer

Add photo

Related Questions

  • Transmission 1 answer

    I'm starting my car put it in reverse pulled out of the driveway went to put it in Drive. It went into drive but it wouldn't engage. When you put it back in park it still roll like it's in neutral ...

    2003 Chevrolet TrailBlazer LT

    -

    Maintenance & Repair

  • Transmission 6 answers

    I started the truck up put it in reverse pulled out of the driveway then put it in Drive but it didn't engage then I put it back in reverse and it didn't engage. Now when I put it back in park the ...

    2003 Chevrolet TrailBlazer LT

    -

    Maintenance & Repair

  • 2007 Chevy TrailBlazer Transmission Problems 3 answers

    My TrailBlazer is having a major problem. When I put it into drive the RPMs fly but the car doesn't even budge. It does the same in Reverse and 123. I don't feel anything when I shift and I read t...

    2007 Chevrolet TrailBlazer

    -

    Maintenance & Repair

  • Transmission 1 answer

    I have a 2003 trailblazer the transmission changes real quick in a straight stretch but when it starts pulling a small hill it won't gear right and just whines. You can stop then take off again An...

    2003 Chevrolet TrailBlazer LS 4WD

    -

    Maintenance & Repair

  • Transmission not shifting 3 answers

    Starting from a stop car is at 20 mph and rpms are bt 3/4. In order for it to shift I have to back off the gas down to 2 mph. Then it will shift but not into 2nd shift. Running 55 mph with 4rpms a...

    2007 Chevrolet Suburban LTZ 1500 4WD

    -

    Maintenance & Repair

TrailBlazer

Looking for a Used TrailBlazer in your area?

CarGurus has 5,377 nationwide TrailBlazer listings starting at $650.

ZIP:

Search Chevrolet TrailBlazer Questions

Chevrolet TrailBlazer Experts

#1 Tom Demyan
Tom Demyan
Reputation 680
#2 dandyoun
dandyoun
Reputation 550
#3 bigdogracer
bigdogracer
Reputation 520
View All

Related Models For Sale

Used Chevrolet Tahoe
1,067 Great Deals out of 32,280 listings starting at $1,495
Used Jeep Grand Cherokee
1,117 Great Deals out of 69,518 listings starting at $1,500
Used GMC Envoy
73 Great Deals out of 2,280 listings starting at $1,500
Used Chevrolet Silverado 1500
2,628 Great Deals out of 148,540 listings starting at $1,800
Used Ford Explorer
1,433 Great Deals out of 71,885 listings starting at $985
Used Chevrolet Impala
951 Great Deals out of 36,332 listings starting at $884
Used Chevrolet Equinox
1,719 Great Deals out of 70,644 listings starting at $1,500
Used Dodge Charger
566 Great Deals out of 28,733 listings starting at $2,275
Used Dodge Durango
456 Great Deals out of 23,002 listings starting at $1,200
Used Ford F-150
3,397 Great Deals out of 203,568 listings starting at $1,273
Used GMC Yukon
539 Great Deals out of 17,748 listings starting at $1,777

Used Cars For Sale

2009 Chevrolet TrailBlazer LT1 4WD For Sale
10 Great Deals out of 92 listings starting at $4,999
2008 Chevrolet TrailBlazer LT1 4WD For Sale
12 Great Deals out of 186 listings starting at $4,150