2004 grand marquis ls cruise stopped working after i degreased the engine. any ideas

5

Asked by Dec 07, 2013 at 08:52 AM about the 2004 Mercury Grand Marquis LS Premium

Question type: Maintenance & Repair

I did use a hose with light spray so i'm leaning towards something electrical.

2 Answers

247,175

Yup, you got moisture in one of your electrical plugs/connections, dry it out.

50

My cruise an horn don't work

2 of 2 people found this helpful.

Your Answer

Add photo

Related Questions

Search Mercury Grand Marquis Questions

Mercury Grand Marquis Experts

#1 Tracy Hooks
Tracy Hooks
Reputation 5,650
#2 kbro
kbro
Reputation 2,120
#3 Js08016
Js08016
Reputation 1,830
View All

Related Models For Sale

Used Ford Crown Victoria
13 Great Deals out of 1,248 listings starting at $1,995
Used Lincoln Town Car
35 Great Deals out of 1,808 listings starting at $1,495
Used Chevrolet Impala
553 Great Deals out of 35,458 listings starting at $899
Used Cadillac DeVille
1,705 listings starting at $1,995
Used Buick LeSabre
21 Great Deals out of 1,939 listings starting at $1,588
Used Chrysler 300
384 Great Deals out of 17,761 listings starting at $1,000
Used Ford F-150
2,089 Great Deals out of 191,500 listings starting at $290
Used Ford Mustang
689 Great Deals out of 44,320 listings starting at $1,500
Used Ford Taurus
272 Great Deals out of 18,688 listings starting at $1,499
Used Honda Accord
1,057 Great Deals out of 66,823 listings starting at $1,000
Used Mercury Marauder
25 listings starting at $9,499
Used Toyota Camry
1,207 Great Deals out of 82,541 listings starting at $750
Used Ford Explorer
914 Great Deals out of 63,252 listings starting at $700

Used Cars For Sale

2007 Mercury Grand Marquis LS Premium For Sale
6 Great Deals out of 102 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.