Changed out the Main Relay, car was running fine till it sat in the sun... The dash lights do not come on when in the II position but do when halfway between II and III. Is it the ignition switch

45

Asked by Aug 02, 2014 at 01:04 PM about the 1994 Acura Legend L

Question type: Maintenance & Repair

I have already replaced the Main Relay in my 1994 Acura Legend L Sedan.  Still having starting issues.  It ran just fine for like 3 weeks, it sat in my driveway in the sun for a few hours and had trouble starting.  After about 3 tries it started up and ran.  I noticed when I was driving the Tachometer and the Odometer at one point had gone almost to 0 and then came back up.  I have read online that it could be the ignition electrical switch.  I did a test and noticed that the dash lights will not come on in the II position but will when in between II and III.

1 Answer

45

Ok so I found out what the problem was :). Yep I am very mechanical. It was the ignition electrical switch. 55.00 and about 20 mins and it was running again :)

Your Answer

Add photo

Related Questions

Search Acura Legend Questions

Acura Legend Experts

#1 maddison
maddison
Reputation 250
#2 Logan Saunders
Logan Saunders
Reputation 180
#3 Monique Bell
Monique Bell
Reputation 140
View All

Related Models For Sale

Used Acura TL
302 Great Deals out of 7,931 listings starting at $2,499
Used Honda Accord
814 Great Deals out of 81,613 listings starting at $899
Used Acura Integra
150 listings starting at $4,000
Used Acura NSX
287 listings starting at $32,995
Used Acura Vigor
4 listings
Used BMW 7 Series
165 Great Deals out of 5,952 listings starting at $3,400
Used BMW 3 Series
1,369 Great Deals out of 37,821 listings starting at $1,500
Used Honda Civic
668 Great Deals out of 77,419 listings starting at $1,000
Used Honda Prelude
7 Great Deals out of 118 listings starting at $1,000