hi its me again about my acura.

Asked by Oct 21, 2013 at 09:43 AM about the 1997 Acura CL 3.0

Question type: Maintenance & Repair

i didnt do a compression test because when i run the motor and leave the crank sensor on
it runs nice no noise no nocking nothing but the minute i clear the code it starts shaking
and drops idel and want to stall. if the valves had bent wouldnt the engine make noise or
burn oil cause mine is quiet and no oil burning.

1 Answer

112,155

Try unhooking the battery for at least ten minutes. This will reset everything. Sometimes this helps.

Your Answer

Add photo

Related Questions

Search Acura CL Questions

Acura CL Experts

#1 ss1007
ss1007
Reputation 240
#2 tenspeed
tenspeed
Reputation 110
#3 Tom Harmon
Tom Harmon
Reputation 100
View All

Related Models For Sale

Used Acura TL
189 Great Deals out of 5,446 listings starting at $999
Used Honda Accord
1,053 Great Deals out of 68,303 listings starting at $1,000
Used Acura RL
24 Great Deals out of 684 listings starting at $2,000
Used Honda Accord Coupe
180 Great Deals out of 10,356 listings starting at $1,495
Used Acura NSX
290 listings starting at $29,995
Used BMW 3 Series
1,024 Great Deals out of 31,545 listings starting at $1,000
Used Honda Civic
883 Great Deals out of 84,980 listings starting at $750
Used Acura Integra
106 listings starting at $1,900

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.