I have a 2007 Mercury Monterrey with 4.2L and it stalls almost every day when first started and put into gear forward or reverse. Once warmed up it appears to be ok. No codes !!!!

Asked by Feb 16, 2016 at 02:32 PM about the 2007 Mercury Monterey Luxury

Question type: Maintenance & Repair

I have a 2007 Mercury Monterrey with 4.2L and it stalls almost every day
when first started and put into gear forward or reverse. Once warmed up it
appears to be ok. No codes !!!! I already had one mechanic look at it and fuel
pressure ok as well as contracts and relays ok. He removed main computer
line and cleaned and put dielectric grease on terminals. I already tried the
MASS air flow sensor and idle control and fuel filter and air filter. I cleaned the
throttle body and checked vacuumed lines. Also there is an intermittent pop
sound from inside air inlet or at least you can hear it from air cleaner area as it
gets magnified. Other than that car runs and shifts fine after warm up. Very
strange and annoying . What the hell could this be !!!!! HELP !

6 Answers

19,150

Did you replace the fuel filter ? And add some seafoam fuel injector cleaner to gas tank.

1 of 1 people found this helpful.

Yes tried both

19,150

When was last time you had a tune up popping noise you hear could be a spark plug miss firing.

I changed plugs last summer and wires

19,150

Does your vehicle have electronic throttle or cable throttle ? Sounds like throttle is staying open all the time instead of slightly closing when cold and opening slowly as vehicle warms up. If you have a cable throttle may have to adjust throttle if electronic throttle may have to replace.

1 of 1 people found this helpful.

It is a cable control. In my mind I am thinking coil pack or electrical . Engine dies fast just after a slight rough idle again only in gear. Happened again this morning. I let it die 3 times then once it got to a stable point it will run fin in gear. I appreciate the advice. I am willing to try anything to get this fixed. Last summer the check engine light did come on and code said plug 3 no good or wires or coil pack. I replaced plugs and wires and light went off. However maybe coil pack was still an issue .

Your Answer

Add photo

Related Questions

Monterey

Looking for a Used Monterey in your area?

CarGurus has 126 nationwide Monterey listings and the tools to find you a great deal.

ZIP:

Search Mercury Monterey Questions

Mercury Monterey Experts

#1 gws
gws
Reputation 140
#2 kbro
kbro
Reputation 90
#3 badgeboy
badgeboy
Reputation 50
View All

Related Models For Sale

Used Mercury Mountaineer
25 Great Deals out of 1,155 listings starting at $1,980
Used Honda Odyssey
248 Great Deals out of 19,844 listings starting at $1,495
Used Chrysler Town & Country
225 Great Deals out of 14,648 listings starting at $1,995
Used Ford Freestar
638 listings starting at $2,899
Used Mercury Mariner
57 Great Deals out of 1,294 listings starting at $2,496
Used Mercury Montego
4 Great Deals out of 284 listings starting at $1,795
Used Mercury Grand Marquis
34 Great Deals out of 1,784 listings starting at $2,250
Used Nissan Quest
71 Great Deals out of 2,655 listings starting at $2,995
Used Toyota Sienna
247 Great Deals out of 28,786 listings starting at $2,180
Used Dodge Grand Caravan
168 Great Deals out of 25,152 listings starting at $2,000
Used Ford Crown Victoria
14 Great Deals out of 1,268 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.