Strange engine electrical problems

15

Asked by Mar 20, 2011 at 03:12 PM about the 1990 Chevrolet Lumina 4 Dr STD Sedan

Question type: Maintenance & Repair

My 90 Lumina 3.1 is having some strange engine issues all at once. Idle surges (installed new IAC motor). Still surges. I pulled the IAC connector. Nothing changed, no voltage from any of the pins with key on or engine running. Also noticed that cooling fan came on imediatly with engine cold when key was switched on. Took a short ride and notice speedometer not working and won't sjift into overdrive. Checked ECM connections, they look okay. With all this happening and no voltage at IAC plg I'm thinking the ECM is bad. Any ideas?

1 Answer

15

It was the ECM. Pep Boy's had one in stock $76. Wow!

1 of 1 people found this helpful.

Your Answer

Chevrolet Lumina Experts

  • #1
    90V6RedHotLuminaEuro
    Reputation
    1,180
  • #2
    John Saffrahn
    Reputation
    1,090
  • #3
    11jonny11
    Reputation
    930
View All

Related Models For Sale

Used Toyota Camry
929 Great Deals out of 80,592 listings starting at $1,440
Used Chevrolet Camaro
434 Great Deals out of 30,717 listings starting at $2,495
Used Ford Taurus
192 Great Deals out of 15,799 listings starting at $1,850
Used Chevrolet Caprice
197 listings starting at $9,995
Used Honda Accord
1,028 Great Deals out of 57,887 listings starting at $1,099
Used Ford Mustang
589 Great Deals out of 36,206 listings starting at $1,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.