coolant level system problem 96 oldsmobile ninety-eight

Asked by Oct 22, 2016 at 01:56 PM about the 1996 Oldsmobile Ninety-Eight 4 Dr Regency Elite Sedan

Question type: Maintenance & Repair

keeps saying coolant level sys prob. how do I fix it?

1 Answer

64,995

Unplug the sensor. If the light on the dash goes off the sensor is bad. Sometimes they get dirty and can't "see" the coolant. If you recently replaced the radiator you may have to drill out the hole for the sensor. If the hole is not drilled out the sensor will remain dry and keep the light on. If you unplug the sensor and the light on the dash stays on there's a short in the wiring or the instrument cluster is bad. HTH. -Jim

Your Answer

Add photo

Related Questions

Search Oldsmobile Ninety-Eight Questions

Oldsmobile Ninety-Eight Experts

#1 Tom Demyan
Tom Demyan
Reputation 140
#2 Travis Willard
Travis Willard
Reputation 130
#2 Js08016
Js08016
Reputation 130
View All

Related Models For Sale

Used Buick LeSabre
5 Great Deals out of 1,978 listings starting at $1,500
Used Cadillac DeVille
10 Great Deals out of 1,622 listings starting at $1,499
Used Chevrolet Impala
523 Great Deals out of 29,491 listings starting at $799
Used Buick Park Avenue
438 listings starting at $3,500
Used Chevrolet Camaro
144 Great Deals out of 32,807 listings starting at $1,995
Used Chevrolet Caprice
151 listings starting at $10,490
Used Pontiac Bonneville
546 listings starting at $3,699
Used Buick Regal
117 Great Deals out of 10,254 listings starting at $3,495