Have 93 olds 98 Regency Elite says-fuel guage sensor problem, oil pressure sensor problems

Asked by May 13, 2014 at 11:37 PM about the 1993 Oldsmobile Ninety-Eight 4 Dr Regency Elite Sedan

Question type: Maintenance & Repair

No instrument panel showing, no fan on the AC - what could be the problem.  Has been sitting for about 4 years or more.  VERY Frustrating!!!  Thanks for your help

1 Answer

105,385

Electrical corrosion sounds like your trouble, you may wind up disassembling the entire instrument panel to get it all cleaned up, then you have in the engine compartment that may also be corroded. Grab your wire brush and emery cloth..

Your Answer

Oldsmobile Ninety-Eight Experts

  • #1
    Travis Willard
    Reputation
    150
  • #1
    Js08016
    Reputation
    150
  • #3
    Tom Demyan
    Reputation
    140
View All

Related Models For Sale

Used Cadillac DeVille
6 Great Deals out of 1,514 listings starting at $1,999
Used Buick Regal
156 Great Deals out of 7,535 listings starting at $3,995
Used Chevrolet Impala
581 Great Deals out of 34,519 listings starting at $900
Used Buick LeSabre
7 Great Deals out of 1,709 listings starting at $899
Used Dodge Ram 1500
432 Great Deals out of 11,118 listings starting at $1,495
Used Pontiac Bonneville
486 listings starting at $2,995
Used Buick Park Avenue
378 listings starting at $1,495
Used Chevrolet Caprice
150 listings starting at $9,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.