my 1995 olds 88 royal will start right up and idle normaly but when i put it in reverse to drive away it goes dead. this offten happens in wet weather

Asked by Apr 07, 2014 at 07:25 PM about the 1995 Oldsmobile Eighty-Eight Royale 4 Dr LS Sedan

Question type: Maintenance & Repair

this happens when i rive a little ways and turn the car off for just a short while and return to go. from reading posts on different sights i have thought it might be idle air control valve sticking or the safety switch or maybe the fuel filter. this happens mostly in wet weather. have changed plugs and wires. car runs fine once it gets going. have been on 200 mile trips with no problem

1 Answer


Maybe something electrical is getting wet enough that when you put it in reverse it hits, say a wet reverse switch and shorts out, then the computer automatically shuts it all down? Hard to say.... Maybe try to get a hold of a manual to find a switch in the shifter and try to water proof it some how? bit of a tricky one. The switch should be in the center console, You might have to take apart the plastic covering around the shifter to get at it, but that's were they usually are.

Your Answer

Oldsmobile Eighty-Eight Royale Experts

  • #1
    Michael Urbanski
  • #2
    John Saffrahn
  • #3
    Tom Demyan
View All

Related Models For Sale

Used Buick LeSabre
9 Great Deals out of 1,213 listings starting at $799
Used Chevrolet Impala
379 Great Deals out of 27,771 listings starting at $1,499
Used Chevrolet Caprice
134 listings starting at $1,350
Used Pontiac Bonneville
340 listings starting at $2,000
Used Mercedes-Benz S-Class
114 Great Deals out of 7,245 listings starting at $1,200
Used Buick Park Avenue
309 listings starting at $4,499
Used Lincoln Town Car
23 Great Deals out of 1,439 listings starting at $1,850

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.