Run's good when cold, after warm up starts to load up and miss, punch the gas and it goes, this problem comes and goes


Asked by Mar 03, 2014 at 08:17 PM about the 1990 Chevrolet Blazer 4WD

Question type: Maintenance & Repair

Replaced temp sender that controls rich/ lean, no help. Will map sensor cause this problem? Also this is a repuilt motor, 35000

1 Answer

Mark Grignon

Check the EGR valve. Clean or replace if necessary.

Your Answer

Add photo

Related Questions

Search Chevrolet Blazer Questions

Chevrolet Blazer Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 1,680
#2 yetilikesbeer
Reputation 1,010
#3 dandyoun
Reputation 630
View All

Related Models For Sale

Used Chevrolet S-10"
9 Great Deals out of 1,813 listings starting at $1,749
Used GMC Jimmy"
371 listings starting at $1,900
Used Ford Explorer"
1,381 Great Deals out of 71,753 listings starting at $300
Used Ford Bronco"
220 listings
Used Jeep Wrangler"
448 Great Deals out of 16,357 listings starting at $2,395
Used Chevrolet C/K 1500"
1,140 listings starting at $2,400
Used Chevrolet Camaro"
839 Great Deals out of 39,080 listings starting at $2,650
Used Ford F-150"
3,237 Great Deals out of 216,704 listings starting at $1,000
Used Chevrolet Suburban"
666 Great Deals out of 24,294 listings starting at $2,000

Used Cars For Sale

2005 Chevrolet Blazer For Sale
14 listings starting at $3,450
2003 Chevrolet Blazer For Sale
151 listings starting at $3,495
2001 Chevrolet Blazer For Sale
228 listings starting at $1,595