My 1990 chevy k1500 stalls when i turn my headlights or heater fan on .. I have replaced my tps sensor.. Coolant temp sensor and map sensor. But the problem remains and only does it when i run either

Asked by Dec 10, 2015 at 07:17 PM about the 1990 Chevrolet C/K 1500 Extended Cab LB 4WD

Question type: General

2 Answers

Check for vacuum leak. Spray carb cleaner around vacuum lines and listen for idle change. If it does u have a leak. U can also safely plug main vacuum line at booster(BUT DON'T DRIVE LIKE THIS), and see if it doesn't stall. If it doesn't then it indicates leak. These motors are very vacuum sensitive and I had similar issue. Also sea foam through main line is great for cleaning and can helphelp. It has instructions on back ofbottle.

65

bad battery? alternator? you would be surprised at the electronics going bad. check all ground wires, fuses and relays before you go dumping money into anything.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,720
  • #2
    John Saffrahn
    Reputation
    2,600
  • #3
    Rowefast
    Reputation
    2,200
View All

Related Models For Sale

Used GMC Sierra 1500
1,013 Great Deals out of 66,364 listings starting at $2,495
Used Ford F-150
2,579 Great Deals out of 199,176 listings starting at $1,300
Used Chevrolet C/K 2500
203 listings starting at $3,994
Used Chevrolet Camaro
445 Great Deals out of 30,848 listings starting at $1,450
Used Chevrolet C/K 3500
3 Great Deals out of 238 listings starting at $1,500
Used Chevrolet S-10
20 Great Deals out of 1,251 listings starting at $1,600

Used Cars For Sale

1998 Chevrolet C/K 1500 For Sale
170 listings starting at $3,500
1997 Chevrolet C/K 1500 For Sale
130 listings starting at $3,795
1996 Chevrolet C/K 1500 For Sale
100 listings starting at $3,888

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.