My 1990 chevy k1500 stalls when i turn my headlights or heater fan on .. I have replaced my tps sensor.. Coolant temp sensor and map sensor. But the problem remains and only does it when i run either

Asked by Dec 10, 2015 at 07:17 PM about the 1990 Chevrolet C/K 1500 Extended Cab LB 4WD

Question type: General

2 Answers

Check for vacuum leak. Spray carb cleaner around vacuum lines and listen for idle change. If it does u have a leak. U can also safely plug main vacuum line at booster(BUT DON'T DRIVE LIKE THIS), and see if it doesn't stall. If it doesn't then it indicates leak. These motors are very vacuum sensitive and I had similar issue. Also sea foam through main line is great for cleaning and can helphelp. It has instructions on back ofbottle.


bad battery? alternator? you would be surprised at the electronics going bad. check all ground wires, fuses and relays before you go dumping money into anything.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
  • #2
    John Saffrahn
  • #3
View All

Related Models For Sale

Used GMC Sierra 1500
885 Great Deals out of 59,068 listings starting at $1,980
Used Ford F-150
2,525 Great Deals out of 219,810 listings starting at $1,222
Used Chevrolet C/K 2500
199 listings starting at $3,495
Used Chevrolet Camaro
243 Great Deals out of 29,880 listings starting at $4,980
Used Chevrolet C/K 3500
173 listings starting at $6,990
Used Chevrolet S-10
9 Great Deals out of 1,005 listings starting at $999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.