I need help

Asked by Dec 31, 2015 at 05:22 AM about the 1992 Chevrolet C/K 1500 454SS RWD

Question type: Maintenance & Repair

I have 350 tbi motor. I can't figure out why
my truck stalls really bad when I put it in
gear. It feels like something is keeping it
from rolling but when it does start rolling, I
wont ever go any faster than 15 mph in any
gears. Could it be the engine control module,
transmission, rear end? I honestly don't
know what it is

1 Answer

48,555

Sounds like your truck is stuck in limp mode. Basically, that means that your computer isn't communicating with a sensor. Could be in the tranny or the engine. It could be a number of things. A bad VSS, shift solenoid, short in the tranny wire harness, etc, etc. Your best bet would be to have your truck scanned for error codes. Otherwise you could be replacing a lot of sensors until you hit the right one.

Your Answer:

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    4,450
  • #2
    John Saffrahn
    Reputation
    2,750
  • #3
    Rowefast
    Reputation
    2,440
View All

Related Models For Sale

Used GMC Sierra 1500
816 Great Deals out of 60,745 listings starting at $1,495
Used Ford F-150
2,398 Great Deals out of 200,117 listings starting at $1,300
Used Chevrolet C/K 2500
187 listings starting at $3,950
Used Chevrolet Camaro
260 Great Deals out of 27,404 listings starting at $2,900
Used Chevrolet C/K 3500
200 listings starting at $4,000
Used Chevrolet S-10
4 Great Deals out of 899 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.