why does my 95 Chevy Silverado with a 5.7 starts up runs fine for about 2 to 3 minutes and then starts really running Like it's starving for gas and shuts off

Asked by Jun 01, 2015 at 02:00 PM about the 1995 Chevrolet C/K 1500 Cheyenne Standard Cab LB

Question type: Maintenance & Repair

2 Answers

it also will run idle fine when its in park or neutral but as soon as I put it in drive it starts cutting out real bad anyone know

3,425

Hello, Just a stab...but those models are know for the coolant temp sensor causing a situation just as you describe. Have someone run a scanner, and see if the sensor starts with a low(cold) reading, and then gradually increases its voltage feedback. Now, that's a given that you don't have vacuum leaks, good tune, etc. Hope this Helps, AskTrannyman

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 3,140
#2 John Saffrahn
John Saffrahn
Reputation 2,440
#3 Rowefast
Rowefast
Reputation 1,740
View All

Related Models For Sale

Used GMC Sierra 1500
873 Great Deals out of 64,532 listings starting at $1,500
Used Ford F-150
2,439 Great Deals out of 210,728 listings starting at $895
Used Chevrolet C/K 2500
221 listings starting at $3,199
Used Dodge Ram 1500
442 Great Deals out of 11,479 listings starting at $700
Used Chevrolet Tahoe
616 Great Deals out of 27,687 listings starting at $600
Used Toyota Tacoma
525 Great Deals out of 37,789 listings starting at $2,900
Used Chevrolet C/K 3500
245 listings starting at $5,000
Used Chevrolet Camaro
135 Great Deals out of 35,355 listings starting at $1,995
Used Chevrolet S-10
4 Great Deals out of 1,426 listings starting at $1,995