Back Running Light Issues

Asked by Oct 22, 2011 at 12:45 PM about the 1995 Chevrolet C/K 1500 Cheyenne Standard Cab LB

Question type: Maintenance & Repair

I have break lights, turn signals, and front lights but I do not have back running lights. I have changed both circuit boards, all bulbs, and every fuse in the in dash fuse box that has anything to do with lighting. If changed out the in engine fuse 50a which says it is lighting. Could the brake lamp relay fuse be the issue or 30a the stop/haz light fuse. I'm really at a lose. I have also checked all wiring.

1 Answer

5

may want to chk the conections at the back there may b corrosion in the plugs

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,600
  • #2
    John Saffrahn
    Reputation
    2,570
  • #3
    Rowefast
    Reputation
    2,170
View All

Related Models For Sale

Used GMC Sierra 1500
886 Great Deals out of 65,336 listings starting at $1,995
Used Ford F-150
2,320 Great Deals out of 182,094 listings starting at $1,000
Used Chevrolet C/K 2500
198 listings starting at $6,495
Used Dodge Ram 1500
393 Great Deals out of 10,914 listings starting at $1,500
Used Chevrolet C/K 3500
229 listings starting at $4,999
Used Chevrolet Tahoe
664 Great Deals out of 39,394 listings starting at $1,000
Used Toyota Tacoma
608 Great Deals out of 42,670 listings starting at $1,500
Used Chevrolet Camaro
410 Great Deals out of 30,658 listings starting at $3,550
Used Chevrolet S-10
8 Great Deals out of 1,217 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.