I have a 1996 Chevy Z71. When your driving it feels like it's skipping. I replaced the spark plugs, wires and distributor cap. Still had the problem. Replaced egr valve still having issues. Any ideas

Asked by Dec 01, 2014 at 12:56 AM about the 1996 Chevrolet C/K 1500 Silverado Standard Cab SB

Question type: Maintenance & Repair

1 Answer

145

I'm assuming automatic transmission, but you could have a slipping transmission or a bad torque converter.

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 3,480
#2 John Saffrahn
John Saffrahn
Reputation 2,530
#3 Rowefast
Rowefast
Reputation 2,110
View All

Related Models For Sale

Used GMC Sierra 1500
769 Great Deals out of 68,175 listings starting at $1,700
Used Ford F-150
2,116 Great Deals out of 192,318 listings starting at $290
Used Chevrolet C/K 2500
207 listings starting at $6,499
Used Dodge Ram 1500
402 Great Deals out of 10,916 listings starting at $1,000
Used Chevrolet Tahoe
638 Great Deals out of 32,888 listings starting at $1,500
Used Toyota Tacoma
549 Great Deals out of 42,548 listings starting at $1,995
Used Chevrolet Camaro
357 Great Deals out of 31,259 listings starting at $2,500
Used Chevrolet S-10
8 Great Deals out of 1,329 listings starting at $1,999
Used Chevrolet C/K 3500
233 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.