I am trying to figure out what is causing my 1997 Chevy Z71 Stepside 4x4 pickup to stop advancing while driving. It is fine for 5 or 6 blocks and then it is like the transmission is slipping. However if I stop and put the truck in park and turn it off and start it back up and put it in drive it will go again for another 5,6,7 blocks and then I have to put it back in park and turn it off and restart it again. I have already eliminated the catalytic converters and still same issue.

Asked by Oct 14, 2016 at 01:27 AM about the 1997 Chevrolet C/K 1500 Silverado Extended Cab Stepside 4WD

Question type: Maintenance & Repair

1 Answer

25

I would have your tyranny checked flushed and be filter put in

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,820
  • #2
    John Saffrahn
    Reputation
    2,650
  • #3
    Rowefast
    Reputation
    2,210
View All

Related Models For Sale

Used GMC Sierra 1500
1,153 Great Deals out of 64,233 listings starting at $999
Used Ford F-150
3,141 Great Deals out of 219,096 listings starting at $1,200
Used Chevrolet C/K 2500
202 listings starting at $6,495
Used Dodge Ram 1500
435 Great Deals out of 11,068 listings starting at $2,000
Used Chevrolet Tahoe
783 Great Deals out of 41,561 listings starting at $1,987
Used Chevrolet Camaro
437 Great Deals out of 31,256 listings starting at $1,450
Used Chevrolet C/K 3500
203 listings starting at $4,199
Used Chevrolet S-10
13 Great Deals out of 1,239 listings starting at $1,550
Used Toyota Tacoma
653 Great Deals out of 45,099 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.