1997 chevy 1500 5.7 v8 4x4 fule and wiring issues

60

Asked by Feb 03, 2015 at 09:58 PM about the 1997 Chevrolet C/K 1500 Silverado Extended Cab LB 4WD

Question type: Maintenance & Repair

Under hood fuse box were the fule pump
relay all the Points on it is dead no power I
put a wire on the grey wire Witch is the fuel
pumps pump wire and it comes on when I
put it on a 12 volt ignition I've tested the
brain and it's good so any wiring ideas I've
kinda narrowed it down

1 Answer

113,605

Have you checked the big red wire that comes from the battery to that box? I had a Tahoe that the wire went bad where it connected to the battery, acid was creeping right through it, had to replace the wire and rework the connections, after that no more starting problems, cured a volt meter problem too.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    4,180
  • #2
    John Saffrahn
    Reputation
    2,720
  • #3
    Rowefast
    Reputation
    2,340
View All

Related Models For Sale

Used GMC Sierra 1500
722 Great Deals out of 58,462 listings starting at $1,900
Used Ford F-150
2,344 Great Deals out of 215,477 listings starting at $1,300
Used Chevrolet C/K 2500
192 listings starting at $3,950
Used Dodge Ram 1500
316 Great Deals out of 9,549 listings starting at $800
Used Chevrolet C/K 3500
179 listings starting at $4,895
Used Chevrolet Tahoe
527 Great Deals out of 36,655 listings starting at $1,375
Used Chevrolet Camaro
224 Great Deals out of 28,922 listings starting at $3,900
Used Toyota Tacoma
439 Great Deals out of 44,078 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.