I keep getting check engine light for a bad oxygen sensor, but I have changed the same sensor more than once. Any ideas?

Asked by Aug 07, 2014 at 01:52 PM about the 1999 Chevrolet C/K 1500 LS Extended Cab RWD

Question type: Maintenance & Repair

The computer says that the bank 1 sensor is bad, but I put a brand new on in it not 3 weeks ago and today the engine light came back on saying that the sensor was bad. This has happened more than once. I put in new injectors, new crank position sensor as well. Any ideas?

1 Answer

20,725

what was the code? p0???. There are a few codes related to the o2 sensor. There isn't one that just says "bad o2 sensor". Sometimes the o2 can go bad, other times there could actually be an issue with the engine. There could also be an issue in the wiring harness. Also was it bank 1 sensor 1 or sensor 2?

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    4,000
  • #2
    John Saffrahn
    Reputation
    2,690
  • #3
    Rowefast
    Reputation
    2,290
View All

Related Models For Sale

Used Chevrolet Silverado 1500
2,716 Great Deals out of 158,224 listings starting at $1,850
Used GMC Sierra 1500
1,100 Great Deals out of 61,833 listings starting at $1,295
Used Ford F-150
3,062 Great Deals out of 230,783 listings starting at $1,300
Used Chevrolet C/K 2500
217 listings starting at $2,495
Used Dodge Ram 1500
312 Great Deals out of 10,752 listings starting at $1,950
Used Chevrolet Tahoe
831 Great Deals out of 40,285 listings starting at $1,900
Used Chevrolet C/K 3500
182 listings starting at $4,000
Used Toyota Tacoma
565 Great Deals out of 40,827 listings starting at $2,995
Used Chevrolet Camaro
390 Great Deals out of 31,491 listings starting at $3,000
Used Chevrolet S-10
8 Great Deals out of 1,143 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.