I keep getting check engine light for a bad oxygen sensor, but I have changed the same sensor more than once. Any ideas?


Asked by Aug 07, 2014 at 01:52 PM about the 1999 Chevrolet C/K 1500 LS 2WD

Question type: Maintenance & Repair

The computer says that the bank 1 sensor is bad, but I put a brand new on in it not 3 weeks ago and today the engine light came back on saying that the sensor was bad. This has happened more than once. I put in new injectors, new crank position sensor as well. Any ideas?

1 Answer

Andrew Olsen

what was the code? p0???. There are a few codes related to the o2 sensor. There isn't one that just says "bad o2 sensor". Sometimes the o2 can go bad, other times there could actually be an issue with the engine. There could also be an issue in the wiring harness. Also was it bank 1 sensor 1 or sensor 2?

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,640
#2 John Saffrahn
John Saffrahn
Reputation 2,260
#3 Rowefast
Reputation 1,190
View All

Related Models For Sale

Used Chevrolet Silverado 1500"
2,445 Great Deals out of 144,778 listings starting at $1,995
Used GMC Sierra 1500"
1,028 Great Deals out of 56,923 listings starting at $2,300
Used Ford F-150"
3,268 Great Deals out of 216,650 listings starting at $1,500
Used Chevrolet C/K 2500"
287 listings starting at $1,995
Used Dodge Ram 1500"
522 Great Deals out of 13,739 listings starting at $995
Used Toyota Tacoma"
623 Great Deals out of 30,504 listings starting at $2,850
Used Chevrolet Tahoe"
1,076 Great Deals out of 36,075 listings starting at $1,700
Used Chevrolet S-10"
13 Great Deals out of 1,811 listings starting at $1,749
Used Chevrolet C/K 3500"
299 listings starting at $5,995
Used Chevrolet Camaro"
797 Great Deals out of 38,852 listings starting at $2,650

Used Cars For Sale