no oil pressure, engine runs fine

Asked by Apr 16, 2015 at 01:56 AM about the 1995 Chevrolet C/K 2500 Cheyenne Extended Cab 4WD

Question type: Maintenance & Repair

So today I took my truck to a friends to get a trailer,hooked up and when I got home
the check guage light eas on and my oil pressure was 0.  Shut the truck off, checked
oil level, full and still looking new, been about 1500 miles on it.  Looked under truck, no
leaking or spraying of oil.  Started truck, pressure guage goes to 20 then drops to 0.  
engine sounds normal, even when revving it.  Guage used to read 80 when starting
and around 40 at operating temp.  Is this the sending unit?  Its a vortec 7.4L with
160,000 miles on it

1 Answer

45

Most probably it is the sending unit or the connection to it is loose. If it was a bad oil pump your engine would already be toast.

1 people found this helpful.

Your Answer

Chevrolet C/K 2500 Experts

  • #1
    Rowefast
    Reputation
    340
  • #2
    COMETGUY61
    Reputation
    200
  • #3
    Andrew Olsen
    Reputation
    150
View All

Related Models For Sale

Used Chevrolet C/K 3500
179 listings starting at $4,895
Used Chevrolet C/K 1500
727 listings starting at $2,499
Used Dodge Ram 2500
147 Great Deals out of 4,934 listings starting at $2,495
Used GMC Sierra 2500
3 Great Deals out of 161 listings starting at $4,800
Used Ford F-250
401 listings starting at $2,300
Used Ford F-150
2,344 Great Deals out of 215,477 listings starting at $1,300
Used GMC Sierra 1500
722 Great Deals out of 58,462 listings starting at $1,900

Used Cars For Sale

1997 Chevrolet C/K 2500 For Sale
16 listings starting at $3,950
1996 Chevrolet C/K 2500 For Sale
17 listings starting at $4,450

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.