Coolant temp sending unit/sensor mine was reading wacko changed the unit still wacko any more ideas. Please

70

Asked by Mar 01, 2013 at 01:06 PM about the 2000 Buick LeSabre Custom Sedan FWD

Question type: Maintenance & Repair

2 Answers

103,885

It could be that the wrong voltage is feeding the gauge. It could be that the sending unit is seeing air and that is causing erratic readings.

1 of 1 people found this helpful.
70

The gauge was working fine. All of a sudden it was reading cooler then normal then a little hotter then normal now the gauge is at 5oclock when its at normal running temp

2 of 2 people found this helpful.

Your Answer

Buick LeSabre Experts

  • #1
    Tom Demyan
    Reputation
    2,360
  • #2
    John Saffrahn
    Reputation
    2,060
  • #3
    Austin Gaboda
    Reputation
    1,490
View All

Related Models For Sale

Used Buick Park Avenue
3 Great Deals out of 359 listings starting at $1,995
Used Chevrolet Impala
551 Great Deals out of 33,419 listings starting at $1,499
Used Buick Regal
151 Great Deals out of 6,596 listings starting at $3,995
Used Buick Century
713 listings starting at $2,500
Used Cadillac DeVille
1,441 listings starting at $2,695
Used Toyota Camry
1,137 Great Deals out of 77,515 listings starting at $1,400
Used Honda Accord
909 Great Deals out of 79,343 listings starting at $1,295
Used Mercury Grand Marquis
23 Great Deals out of 1,597 listings starting at $1,000
Used Chevrolet Malibu
1,126 Great Deals out of 57,849 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.