I have replaced the motor mount on my 2003 buick century twice, along with the cv axil, lower control arm, and wheel bearing on the passenger side and the car is still squeeking and not handling right, what else could it be?

Asked by Jun 08, 2017 at 09:42 PM about the 2003 Buick Century Sedan FWD

Question type: Maintenance & Repair

2 Answers


Was the motor mount oily ? For these things to be related I think the problem is serious , A professional shop with the right equipment can set your alignment and camber , unless you see an obvious problem those are things you can't generally do in the driveway , unless you're chuck norris .

Thank you

Your Answer

Buick Century Experts

  • #1
    John Saffrahn
  • #2
    Tom Demyan
  • #3
    John Pate
View All

Related Models For Sale

Used Buick LeSabre
9 Great Deals out of 1,213 listings starting at $799
Used Buick Regal
108 Great Deals out of 4,259 listings starting at $5,979
Used Chevrolet Impala
379 Great Deals out of 27,771 listings starting at $1,499
Used Buick Park Avenue
309 listings starting at $4,499
Used Chevrolet Malibu
664 Great Deals out of 48,938 listings starting at $1,500
Used Toyota Camry
890 Great Deals out of 73,115 listings starting at $1,400
Used Honda Accord
592 Great Deals out of 92,752 listings starting at $1,495
Used Chevrolet Monte Carlo
964 listings starting at $3,300
Used Honda Civic
398 Great Deals out of 52,416 listings starting at $1,200
Used Ford Taurus
153 Great Deals out of 15,596 listings starting at $1,900
Used Pontiac Grand Prix
1,920 listings starting at $3,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.