I have a 2001 Buick Century and my trac off light won't go off. There's no traction control button and what could cause this??

Asked by Jul 19, 2012 at 08:26 AM about the 2001 Buick Century Custom

Question type: Maintenance & Repair

1 Answer

257,895

Check for dirty/faulty connectors and/or wires at the wheel speed sensors.

3 of 3 people found this helpful.

Your Answer

Buick Century Experts

  • #1
    John Saffrahn
    Reputation
    970
  • #2
    Tom Demyan
    Reputation
    800
  • #3
    John Pate
    Reputation
    560
View All

Related Models For Sale

Used Buick LeSabre
18 Great Deals out of 1,771 listings starting at $1,000
Used Buick Regal
172 Great Deals out of 8,824 listings starting at $4,800
Used Chevrolet Impala
541 Great Deals out of 35,257 listings starting at $900
Used Honda Accord
1,015 Great Deals out of 60,156 listings starting at $1,099
Used Toyota Camry
942 Great Deals out of 82,536 listings starting at $999
Used Chevrolet Malibu
980 Great Deals out of 65,650 listings starting at $1,000
Used Buick Park Avenue
3 Great Deals out of 397 listings starting at $1,295
Used Ford Focus
810 Great Deals out of 55,800 listings starting at $800
Used Honda Civic
786 Great Deals out of 70,036 listings starting at $1,500
Used Chevrolet Camaro
445 Great Deals out of 30,844 listings starting at $1,450
Used Cadillac DeVille
1,548 listings starting at $2,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.