1999 Buick Century starting problem after replacing mileage meter resistors

Asked by Nov 06, 2016 at 10:04 AM about the 1999 Buick Century Custom

Question type: Maintenance & Repair

Car will start sometimes and runs great as long as I don't shut off,then only clicking sound..no warning lights on...new battery..

1 Answer

Me Again!! The starting problem happened a week after I replaced 4 150 ome resistors to get my odometer and gear selector dash light working,that's working fine now.... To make long story short...broke down yesterday..just a clicking sound tried boosting new battery etc. tried every few hours after only a clicking sound would not catch! had it towed to shop..more then likely it will start,but will happen again ..there's a glitch somewhere!!

Your Answer

Buick Century Experts

  • #1
    John Saffrahn
    Reputation
    970
  • #2
    Tom Demyan
    Reputation
    800
  • #3
    John Pate
    Reputation
    540
View All

Related Models For Sale

Used Buick Regal
180 Great Deals out of 9,190 listings starting at $2,500
Used Buick LeSabre
16 Great Deals out of 1,880 listings starting at $999
Used Chevrolet Impala
516 Great Deals out of 33,770 listings starting at $950
Used Buick Park Avenue
422 listings starting at $1,295
Used Honda Accord
1,098 Great Deals out of 61,486 listings starting at $999
Used Toyota Camry
1,048 Great Deals out of 71,326 listings starting at $295
Used Chevrolet Malibu
1,121 Great Deals out of 71,677 listings starting at $1,896
Used Honda Civic
825 Great Deals out of 72,772 listings starting at $1,000
Used Ford Mustang
712 Great Deals out of 38,301 listings starting at $895
Used Nissan Altima
1,044 Great Deals out of 75,008 listings starting at $1,200
Used Nissan Maxima
283 Great Deals out of 23,068 listings starting at $899

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.