1999 Buick Century starting problem after replacing mileage meter resistors

Asked by Nov 06, 2016 at 10:04 AM about the 1999 Buick Century Custom

Question type: Maintenance & Repair

Car will start sometimes and runs great as long as I don't shut off,then only clicking sound..no warning lights on...new battery..

1 Answer

Me Again!! The starting problem happened a week after I replaced 4 150 ome resistors to get my odometer and gear selector dash light working,that's working fine now.... To make long story short...broke down yesterday..just a clicking sound tried boosting new battery etc. tried every few hours after only a clicking sound would not catch! had it towed to shop..more then likely it will start,but will happen again ..there's a glitch somewhere!!

Your Answer

Add photo

Related Questions

Search Buick Century Questions

Buick Century Experts

#1 John Saffrahn
John Saffrahn
Reputation 850
#2 Tom Demyan
Tom Demyan
Reputation 670
#3 John Pate
John Pate
Reputation 340
View All

Related Models For Sale

Used Buick LeSabre
9 Great Deals out of 2,368 listings starting at $1,768
Used Buick Regal
209 Great Deals out of 11,280 listings starting at $1,995
Used Chevrolet Impala
998 Great Deals out of 36,811 listings starting at $1,800
Used Buick Park Avenue
502 listings starting at $3,975
Used Honda Accord
1,264 Great Deals out of 78,832 listings starting at $969
Used Ford Taurus
368 Great Deals out of 22,720 listings starting at $1,499
Used Chevrolet Malibu
1,154 Great Deals out of 80,725 listings starting at $2,495
Used Toyota Camry
1,525 Great Deals out of 101,602 listings starting at $700
Used Nissan Altima
1,350 Great Deals out of 86,045 listings starting at $695
Used Honda Civic
1,173 Great Deals out of 67,654 listings starting at $1,500
Used Pontiac Grand Prix
31 Great Deals out of 3,796 listings starting at $1,195
Used Chevrolet Monte Carlo
17 Great Deals out of 1,734 listings starting at $1,695