no power to ign module

Asked by Apr 25, 2011 at 09:05 PM about the 1994 Chevrolet Cavalier VL Sedan FWD

Question type: Maintenance & Repair

my car died and wouldent start back so i changed ignition module/coil packs and so now im not even getting power to the ignition module im getting fuel so im pretty sure its not the crank sensor what could cause this

2 Answers

1,945

Make sure your battery is charged and the terminals are clean. And look at the wireing harness for any damage.

1 people found this helpful.
115

sure sounds like the crankshaft sensor to me. check it. it's an inexpensive part .

Your Answer:

Chevrolet Cavalier Experts

  • #1
    John Saffrahn
    Reputation
    3,240
  • #2
    dandyoun
    Reputation
    1,460
  • #3
    mbar1
    Reputation
    1,290
View All

Related Models For Sale

Used Chevrolet Impala
431 Great Deals out of 25,967 listings starting at $950
Used Honda Civic
407 Great Deals out of 49,585 listings starting at $1,495
Used Chevrolet Camaro
240 Great Deals out of 27,311 listings starting at $2,077
Used Honda Accord
582 Great Deals out of 104,445 listings starting at $1,225
Used Ford Mustang
256 Great Deals out of 38,498 listings starting at $1,350
Used Toyota Corolla
599 Great Deals out of 66,928 listings starting at $1,460
Used Toyota Camry
752 Great Deals out of 73,889 listings starting at $1,250
Used Pontiac Sunfire
215 listings starting at $2,972
Used Nissan Altima
737 Great Deals out of 66,542 listings starting at $1,000
Used Chevrolet Corvette
90 Great Deals out of 15,068 listings starting at $3,620

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.