no power to ign module

Asked by Apr 25, 2011 at 09:05 PM about the 1994 Chevrolet Cavalier VL

Question type: Maintenance & Repair

my car died and wouldent start back so i changed ignition module/coil packs and so now im not even getting power to the ignition module im getting fuel so im pretty sure its not the crank sensor what could cause this

2 Answers

1,715

Make sure your battery is charged and the terminals are clean. And look at the wireing harness for any damage.

1 out of 1 people think this is helpful.
115

sure sounds like the crankshaft sensor to me. check it. it's an inexpensive part .

Your Answer

Add photo

Related Questions

Search Chevrolet Cavalier Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Chevrolet Cavalier Experts

#1 John Saffrahn
John Saffrahn
Reputation 2,760
#2 dandyoun
dandyoun
Reputation 1,260
#3 mbar1
mbar1
Reputation 1,120
View All

Related Models For Sale

Used Chevrolet Impala
935 Great Deals out of 35,377 listings starting at $1,700
Used Honda Civic
859 Great Deals out of 70,031 listings starting at $1,200
Used Chevrolet Camaro
445 Great Deals out of 40,684 listings starting at $3,500
Used Ford Mustang
577 Great Deals out of 42,797 listings starting at $1,699
Used Toyota Corolla
973 Great Deals out of 67,452 listings starting at $1,595
Used Chevrolet Corvette
289 Great Deals out of 20,545 listings starting at $3,688
Used Honda Accord
984 Great Deals out of 75,076 listings starting at $899
Used Chevrolet Monte Carlo
19 Great Deals out of 1,684 listings starting at $2,900
Used Toyota Camry
1,215 Great Deals out of 96,011 listings starting at $1,250
Used Dodge Neon
906 listings