all lights work except rear right when i brake & turn signal, im confused as to why when i have my lights off. my brake light wont work

Asked by Apr 19, 2015 at 11:41 AM about the 1995 Chevrolet Suburban C1500

Question type: Maintenance & Repair

2 Answers

7,615

It's either a bad bulb, bad bulb socket or broken wire

14,725

My first guess is a bulb. Change that. It also may be a bad grown wire. Check for cracks in the wire, or bad connection or corrosion on the connections.

Your Answer

Add photo

Related Questions

Search Chevrolet Suburban Questions

Chevrolet Suburban Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 1,010
#2 Neal Turner
Neal Turner
Reputation 890
#2 Eric Fritz
Eric Fritz
Reputation 890
View All

Related Models For Sale

Used Chevrolet Tahoe
598 Great Deals out of 33,195 listings starting at $1,375
Used GMC Yukon
439 Great Deals out of 20,486 listings starting at $1,495
Used Ford F-150
2,089 Great Deals out of 191,500 listings starting at $290
Used GMC Suburban
165 listings starting at $3,000

Used Cars For Sale

2017 Chevrolet Suburban For Sale
12 Great Deals out of 10,192 listings starting at $38,842
2016 Chevrolet Suburban For Sale
29 Great Deals out of 1,391 listings starting at $36,200
2015 Chevrolet Suburban For Sale
20 Great Deals out of 1,048 listings starting at $26,997
2014 Chevrolet Suburban For Sale
8 Great Deals out of 423 listings starting at $17,900
2013 Chevrolet Suburban For Sale
22 Great Deals out of 550 listings starting at $11,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.