I have a 95Lumina LS that does'nt idle smoothly and acts like it has lost all power. I replaced the fuel pump and fuel filter . Do you think it could be the sensors or catalityc converter?

Asked by slk2012 Jul 13, 2014 at 02:23 PM about the 1995 Chevrolet Lumina LS Sedan FWD

Question type: Maintenance & Repair

I this 95 lumina ls in 2011 and I have already had to replace the fuel pump/filter 3 times,
along with a new ignition box, spark plugs/wires only to have it die on me in the middle of a major intersection.  Just recently I replaced the fuel pump/ filter only to have run worse.
Now it seems to have lost it's power can't drive it up the driveway and it runs like the timing is out.  Any ideas of what's going on with this car?

1 Answer

190,075

Sounds like dirty/faulty idle air control valve and or dirty throttle plate. Other than going dead when you slow down does it drive good at highway speeds? If so I would check the two items I have listed.

3 people found this helpful.

Your Answer:

Own this car?

Share your experience with others.

1995 Chevrolet Lumina

Review another car

CarGurus Experts

  • #1
    90V6RedHotLuminaEuro
    Reputation
    1,620
  • #2
    John Saffrahn
    Reputation
    1,300
  • #3
    11jonny11
    Reputation
    1,160
View All

Know more, shop wisely

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.