wont move in any gear fluid clean linkage works fine can it be electrial?

Asked by Jun 26, 2015 at 04:34 PM about the 1995 Chevrolet Cavalier Base

Question type: Maintenance & Repair

accelerated from light had no noises or bangs just lost all power to car engine runs fine

1 Answer

20,400

Shift control module could be bad.

1 of 1 people found this helpful.

Your Answer

Chevrolet Cavalier Experts

  • #1
    John Saffrahn
    Reputation
    3,060
  • #2
    dandyoun
    Reputation
    1,380
  • #3
    mbar1
    Reputation
    1,230
View All

Related Models For Sale

Used Honda Civic
767 Great Deals out of 60,151 listings starting at $950
Used Chevrolet Impala
568 Great Deals out of 34,334 listings starting at $900
Used Chevrolet Camaro
423 Great Deals out of 31,244 listings starting at $1,450
Used Toyota Corolla
928 Great Deals out of 63,626 listings starting at $1,850
Used Honda Accord
1,099 Great Deals out of 71,973 listings starting at $1,100
Used Ford Mustang
571 Great Deals out of 38,809 listings starting at $1,895
Used Pontiac Sunfire
293 listings starting at $2,100
Used Nissan Altima
1,240 Great Deals out of 77,363 listings starting at $1,695
Used Chevrolet Corvette
168 Great Deals out of 17,408 listings starting at $3,000
Used Nissan Sentra
749 Great Deals out of 50,222 listings starting at $2,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.