Transmission won't go into 2nd gear

300

Asked by Aug 09, 2013 at 07:26 PM about the 1996 Chevrolet Blazer LT 4-Door 4WD

Question type: Maintenance & Repair

I have changed filter 2 times and changed
1-2 solenoid with correct fluid and it still
does same thing... I let it run about 10 mins
and played with the gear and let run about 5
mins then drove it but it drives and hits 35
and after that it revs up and rpm goes high
till it slows down... Can anyone help me
please.....

1 Answer

275,965

Did you reinstall the small gasket between the valve body and the filter? Sometimes this is missed and causes a flare of the 1-2 shift, and only shifts if you let off the gas.

1 of 1 people found this helpful.

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,210
  • #2
    yetilikesbeer
    Reputation
    1,490
  • #3
    Rowefast
    Reputation
    1,150
View All

Related Models For Sale

Used Chevrolet Tahoe
784 Great Deals out of 40,138 listings starting at $1,799
Used Chevrolet S-10
7 Great Deals out of 1,107 listings starting at $950
Used GMC Jimmy
167 listings
Used Ford Bronco
194 listings
Used Chevrolet Camaro
358 Great Deals out of 31,467 listings starting at $3,495
Used Ford F-150
2,943 Great Deals out of 230,828 listings starting at $1,300
Used Ford Explorer
1,018 Great Deals out of 67,538 listings starting at $1,200
Used Jeep Grand Cherokee
859 Great Deals out of 72,064 listings starting at $900
Used Chevrolet C/K 1500
782 listings starting at $2,600
Used Chevrolet Suburban
494 Great Deals out of 23,279 listings starting at $2,895
Used Chevrolet Impala
466 Great Deals out of 31,445 listings starting at $1,000

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.