My truck is a 97 chevy suburban and the voltage gauge ticks even though i changed the alternator and battery. the speedometer reads 100 mph even when not moving,sometimes when starting it goes to 70?

Asked by May 04, 2015 at 06:35 PM about the 1997 Chevrolet Suburban K1500 4WD

Question type: Maintenance & Repair

1 Answer

8,055

Sounds a bad gauge cluster

Your Answer

Chevrolet Suburban Experts

  • #1
    Andrew Olsen
    Reputation
    1,060
  • #2
    Neal Turner
    Reputation
    980
  • #3
    Eric Fritz
    Reputation
    940
View All

Related Models For Sale

Used Chevrolet Tahoe
787 Great Deals out of 41,984 listings starting at $1,987
Used GMC Yukon
598 Great Deals out of 20,736 listings starting at $2,500
Used Ford Expedition
378 Great Deals out of 17,283 listings starting at $1,489
Used Ford F-150
3,279 Great Deals out of 221,661 listings starting at $1,200
Used GMC Sierra 1500
1,194 Great Deals out of 64,560 listings starting at $999
Used Lincoln Navigator
84 Great Deals out of 3,748 listings starting at $1,795
Used Ford Explorer
1,231 Great Deals out of 69,461 listings starting at $1,000

Used Cars For Sale

2017 Chevrolet Suburban For Sale
107 Great Deals out of 7,070 listings starting at $38,500
2016 Chevrolet Suburban For Sale
62 Great Deals out of 1,504 listings starting at $30,500
2015 Chevrolet Suburban For Sale
51 Great Deals out of 1,738 listings starting at $22,997
2014 Chevrolet Suburban For Sale
20 Great Deals out of 562 listings starting at $13,495
2013 Chevrolet Suburban For Sale
31 Great Deals out of 706 listings starting at $10,988

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.