My instrument cluster does not work when installed...

5

Asked by Sep 07, 2019 at 06:49 PM about the 2002 Buick Park Avenue FWD

Question type: Maintenance & Repair

My instrument panel has not worked
for over a year now...all the lights come
on...the flasher lights work...the
highbeam indicator works...the seat
belt light works and the security light
flashes...so...when I took the cluster
out to look at it I moved the harness
around and all of the sudden all gauges
worked...???...so after looking it over
and cleaning it up I put it back in and
still working then as soon as I put it in
line with the screw holes and put them
in wham...the gauges stop working so I
pulled it out a little moved it around and
they work again then I put it back in
screw it down they stop...???

No Answers Yet

Your Answer:

Buick Park Avenue Experts

  • #1
    jateen29
    Reputation
    2,650
  • #2
    Jking1838
    Reputation
    1,520
  • #3
    Jim Campbell
    Reputation
    860
View All

Find great deals from top-rated dealersTM

Search

Related Models For Sale

Used Buick LeSabre
878 listings
Used Buick Regal
91 Great Deals out of 2,389 listings starting at $2,999
Used Toyota Camry
1,170 Great Deals out of 72,258 listings starting at $1,395
Used Buick Century
409 listings starting at $599
Used Toyota Avalon
153 Great Deals out of 6,973 listings starting at $1,000
Used Cadillac DeVille
854 listings starting at $2,995
Used Lincoln Town Car
14 Great Deals out of 1,107 listings starting at $1,500
Used Toyota Highlander
937 Great Deals out of 49,345 listings starting at $1,000
Used Chevrolet Silverado 1500
3,160 Great Deals out of 176,051 listings starting at $700

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.