Hi guys, it's me again. GUESS WHAT?!?! I got a new car!!! (Ok, it's not exactly "new") in fact, it's 20 years old, but it's been SUPER-babied...a 94 Volvo 960 wagon, with (perfect) leather upholstery & wood-grain as far as the eye can see...she's beautiful, really. (Tho my oldest offspring calls her a "granny-mobile" coz he's pissed that I dit'n go with a 94 Camaro instead.) Oh well...tough titty for him. Anyhoo...she runs like a good dream except for one thing.....the ac. Now it heats & cools mind you, though I haven't a clue HOW, as there is no actual air coming out of the vents! What I mean is...if I give it 3 or 4 minutes, the temp inside the car DOES actually change, but there is no air actually blowing OUT of the vents! Anybody have a clue? Thanks iin advance! You guys are awesome! :)


Asked by Mar 09, 2014 at 11:12 PM about the 1994 Volvo 960 Level II Wagon

Question type: Maintenance & Repair

1 Answer


Sounds like the blower motor for the climate control isn't working. Check the wiring, switch, and the motor itself.

Best Answer Mark helpful

Your Answer

Volvo 960 Experts

  • #1
    Reverend RobDiesel
  • #2
    Tom Demyan
  • #3
View All

Related Models For Sale

Used Volvo 940
9 listings
Used Volvo 240
26 listings
Used Volvo 850
34 listings
Used Volkswagen Jetta
403 Great Deals out of 28,090 listings starting at $1,650

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.