my 850 was charged at 60 amps by mistake and the battery blew. now with new battery no turnover at all

Asked by Mar 01, 2014 at 09:14 PM about the 1994 Volvo 850 GLT

Question type: Maintenance & Repair

the problem began when combining a 94 and 95 the vacuum on the fuel injection did not
work. initially it it ran but would shut off after 2 seconds. fuel pump fuse problem then with
that fixed it would idle but not rev. fixed vac but no battery so accidently left charger on 60
amp and blew the battery now with new battery i get a click but no crank at all. ignition
cylander?

1 Answer

111,185

Check your battery connections. I suspect they might be bad cable ends with battery exploding. Also check where the negative cable goes to frame and motor. Could have caused an issue at these spots also.

Your Answer

Add photo

Related Questions

Search Volvo 850 Questions

Volvo 850 Experts

#1 Tom Demyan
Tom Demyan
Reputation 180
#2 Mike Mettrick
Mike Mettrick
Reputation 60
#2 Guttermonk
Guttermonk
Reputation 60
View All

Related Models For Sale

Used Volvo 240
38 listings
Used BMW 3 Series
959 Great Deals out of 30,714 listings starting at $1,000
Used Volvo 940
7 listings
Used Volvo 960
16 listings
Used BMW 5 Series
481 Great Deals out of 15,878 listings starting at $1,500
Used BMW M3
42 Great Deals out of 1,336 listings starting at $4,660

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.