My1999 blazer spits and spuders when I first take off once it's going it's fine and will not do it again until it's shut off. The oil pressure gauge is also going to zero when I let off the gas

Asked by Jun 28, 2012 at 12:07 AM about the 1999 Chevrolet Blazer 4 Door LS 4WD

Question type: Maintenance & Repair

1 Answer

19,055

I would have the oil pressure tested with another gauge, if it's a 0 then that's bad, the oil pump may be going or worse. As far as the sputtering, maybe it's haveing problems with the spider injectors. Those 4.3's are notorious for that. They leak into the intake and cause rough starts and may cause rough running intially.

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,030
  • #2
    yetilikesbeer
    Reputation
    1,330
  • #3
    Rowefast
    Reputation
    1,030
View All

Related Models For Sale

Used Chevrolet Tahoe
641 Great Deals out of 36,921 listings starting at $1,800
Used Chevrolet S-10
8 Great Deals out of 1,275 listings starting at $1,800
Used Chevrolet Silverado 1500
2,132 Great Deals out of 181,503 listings starting at $1,898
Used GMC Jimmy
248 listings starting at $1,900
Used Ford Explorer
800 Great Deals out of 62,675 listings starting at $1,425
Used Chevrolet Camaro
418 Great Deals out of 31,676 listings starting at $2,395
Used Jeep Grand Cherokee
869 Great Deals out of 70,866 listings starting at $995
Used Chevrolet C/K 1500
890 listings starting at $3,195
Used Jeep Wrangler
271 Great Deals out of 15,725 listings starting at $2,997
Used Jeep Cherokee
367 Great Deals out of 40,996 listings starting at $1,500
Used Ford F-150
2,116 Great Deals out of 181,536 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.