No spark after all changes

Asked by Apr 11, 2015 at 04:44 PM about the 1999 Chevrolet Blazer LS 2-Door RWD

Question type: Maintenance & Repair

Why no fire after replacing cam
sensor,module, pick up, all the.T Body
sensors, all of timein set why no
spark, fuel pump all new,new
fuelpump ,pcvfvalve,

1 Answer

5

you're crank sensor is bad

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,180
  • #2
    yetilikesbeer
    Reputation
    1,440
  • #3
    Rowefast
    Reputation
    1,110
View All

Related Models For Sale

Used Chevrolet Tahoe
900 Great Deals out of 39,725 listings starting at $2,300
Used Chevrolet S-10
11 Great Deals out of 1,191 listings starting at $1,980
Used Chevrolet Silverado 1500
2,949 Great Deals out of 163,033 listings starting at $1,500
Used GMC Jimmy
201 listings starting at $2,989
Used Ford Explorer
1,216 Great Deals out of 65,286 listings starting at $1,200
Used Chevrolet C/K 1500
807 listings starting at $2,995
Used Ford Mustang
454 Great Deals out of 42,976 listings starting at $1,488
Used Chevrolet Camaro
510 Great Deals out of 31,319 listings starting at $2,495
Used Ford F-150
3,309 Great Deals out of 227,155 listings starting at $1,250
Used Chevrolet Suburban
502 Great Deals out of 23,256 listings starting at $1,250
Used Jeep Grand Cherokee
947 Great Deals out of 67,989 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.