1: When I press gas pedal, the car does not pick up as it should .......what could be the possible cause for it...

880

Asked by Apr 05, 2011 at 01:06 AM about the 1995 Mercedes-Benz C-Class C 220 Sedan

Question type: Maintenance & Repair

81 Answers

bad TPS,or run a can of seafome fuel injector cleaner in a full tank of gas.when was the air filter last changed.

69 of 69 people found this helpful.
4,875

I will need more to go on, It could be a number of things. Try being more specific with the description of the problem “...Pick up as it should...” is a little vague for anybody to give a useful answer. Does it sputter, misfire or hesitate? Does the transmission not change down to a lower gear?

98 of 98 people found this helpful.

his question is plain and simple,to the point.

73 of 73 people found this helpful.
245

Check the spark plug

23 of 23 people found this helpful.

WHICH ONE????

26 of 26 people found this helpful.
880

it does not sputter or misfire but there is delay in taking the pick up when gas paddle is pushed a little hard. The car dies down and then starts taking motion/pick. There does not seem to b problem with transmission.

88 of 88 people found this helpful.
4,875

This sound like what my car did when the mass air flow sensor was on it's last leg. First, to make sure, go to Pep Boys and have them check the computer for any fault codes. This will point you in the right direction if there is a code stored on the computer. It seems the car is misfiring the engine is under load, like when you are trying to accelerate. It bogs down as it misfires, then picks up after awhile ( you might not detect it as a misfire just a delay from when you step on the gas to when the car starts to move). Here are a few things that could cause this kind of drivability problem: Bad Mass Air Flow sensor Bad plugs, plugs wires or coils Clogged fuel filter starving the engine of gas ( I am a bit doubtful of this one) But I would get a reading from the computer first before I start changing anything. If there is a problem a fault code will be stored on the computer.

73 of 73 people found this helpful.

only if it has a ses light on,if not no need for a scan.

7 of 7 people found this helpful.
4,875

On the contrary. A “pending code” will not trigger the light on the dash but the computer will still record a fault code if there is a faulty component. The light on the dash only light up with major fault code that is stored in freeze frame.

23 of 23 people found this helpful.
4,875

Actually it was too simple, it needed to be narrowed down if a solution is to be found. A vague question like that only begs for more questioning and no solutions

8 of 8 people found this helpful.
395

i had the same problem before ,my car is 99 C 230 kump , it is the mas air flow sensor , the price for that part is $400 from the dealer , u can buy it from ebay for around $170 . this sensor is located on the left side of the engine bay next to the fan , u can change it urself just use a flat head good luck p.s make sure that sensor u buy is Bosch , dont buy any other brands cause they suck

25 of 25 people found this helpful.
4,875

This is true you can get the entire Mass air flow sensor unit for around $400 buck but all you need is the Sensor insert which you can get at Germanstar.net for around $139

15 of 15 people found this helpful.
395

to replace the sensor by itself , u need special tool to remove it and its a MBenz tool only ..the price $400 is for OEM part, on ebay Bosch price is $168 + shipping

11 of 11 people found this helpful.
4,875

Yes, you'll need a special tool but it's not exclusive to MB, and it's not that special anymore. I bought a set at Advanced Auto Parts. Its an Allen Key with a hollow tip

11 of 11 people found this helpful.
415

my c180 is also has delay in reving, if I try to accelerate harsh it will lower the revs, unless I rev gently it climbs to just under 4000rpm and just drops, can any 1 help me plz

35 of 35 people found this helpful.
70

Mass Air Flow Sensor is bad or going bad. very easy to uninstall and install usually cost about $120.00 but if your check engine light is on I recommend you get a check done before buying the part

7 of 7 people found this helpful.
140

its a matter of only four things spark plugs plug wires air filter clogged fuel pump or fuel filter

14 of 14 people found this helpful.
450

I have mercedez c180 2002 model. pick of car is not even I press full padel of pick....it takes time after that certaintly take pick. even on the Parking mode pressing the pick paddel RPM is not going up?? some one told me it is gear problem but car change automatically....I am not very sure what is fault???any one know about it..kindly inform me... I will be very thankful to your for this act of kindness. my email address is mfurqankhan@hotmail.com

45 of 45 people found this helpful.
140

I have a Hyundai Elantra 2002 Stick Shift. When I go to take off it goes slow until it reves up so much I have to change the gear then when I put it in 2nd sometimes it will go and sometimes it just reves. that is the same with all the gears if I switch the gear it will go then rev I will have to let off the gas and try to give it gas or just switch back into a lower gear. can someone tell me this is not the Transmission PLEASE!!!

14 of 14 people found this helpful.
205

Folks I have a 1997 C230 Mercedes, This seems to be having the same problem, but when it Idles it runs rough and when driving it is stalling out but will re-start. I had the codes checked, came up with bad cam sensor. I replaced it as well the MAF. The vehicle is still stalling and runs rough

20 of 20 people found this helpful.
140

a quetion

11 of 11 people found this helpful.
140

i have question

3 of 3 people found this helpful.
20,345

Yes?

7 of 7 people found this helpful.
215

I have a c280 yr 2000 I have the problem of bad idle, stalls at drive through, wait at light or stop sign. So far I have had the following replaced: crankshaft sensor $400.00 air flow hose thing $350.00 6 spark plugs and #2 ignition coil $581.00 temp 80 or 85 when it stalls and still nothing It seem as if the engine gets hot

14 of 14 people found this helpful.
100

If you hesitate from door it's the inline filter or the one on the pump itself this should help the next thing would be a coil or the plugs if it still stalls after this go to the mass airflow sensor note! 10 years experience with foreign and domestic vehicles

10 of 10 people found this helpful.
180

I need help I have a Buick century 2003 it hesitate to want to go it misfires it goes really slow I can't even put it on the highway. I got the egress valve done and a tune up but still tapping the gas as hard as I can it goes nowhere. Please someone help

18 of 18 people found this helpful.
50

I have a 2004 ford Escape. Its doing the same exact thing the original poster stated. But in addition it smells like its burning when idling in park or at a stop light. It idles around 300rpm (not rough). It makes a loud clunking noise when shifting gears up a hill. And now at low speeds it feels like its bouncing. over the past 3 months I've had it into pep boys 3 times. First two there were no lights on and they said they couldn't find anything wrong. A week after I had it in the second time the engine light started blinking. They told me to have it towed because a blinking light is a serious problem. They said cylinder 5 was misfiring, and that I needed all coils and spark plugs replaced because if I only replaced one I'd be back in a few weeks to replace the rest. $1100 they also said escapes are notorious for misfiring because the computer went bad... so I might need my computer replaced if it happens again. I think I'm in the clear of a bad computer. But after all of that my original problems still exist and are getting worse.

5 of 5 people found this helpful.
215

I did find out the problem with my engine. The water pump was bad and the engine cut it self off to protect the system from over heating. Thank you for all of your input.

5 of 5 people found this helpful.
1,385

I have a automobile and the gas air mixture unit mounted in the valley of my V8 has flames coming out of it every so often and mid tail pipe explosions coming out of the tail pipe the motor will not run smoothly and to get it to tick over I give it full gas from the foot operated lever and the motor has no power I think the gas storage unit has water in it I am from the UK and have translated this into American so you can understand the correct terminology any help would be great thanks

5 of 5 people found this helpful.
310

I have a 2003 c240 4matic. I am no car expert so I may not be using the right verbiage. About a month ago the car started to act as if it was going to turn off while I was stopped at a light. Prior to that, the car did not like when I would step on the gas pedal. It favored a slow accelaration. Yesteday, I turned it on and let it warm up as the temp have been in the 20s here. I drive it for about 2 minutes and when i tried to accelarate, it wouldn't. Seems like it may be stuck in the first gear. The check engine light came on with a P0123 code. No other codes with it. Has anyone experienced this? My email address is aalihic@comcast.net Thanks for everyone's comments.

31 of 31 people found this helpful.
160

my mercedes when i paddle it loses power and when i turn of the car the battery goes dead what could it be?

16 of 16 people found this helpful.
150

My Mercedes C220 fails to pick up speeds and stalls sometimes. It also has a hard start sometimes, I have to supply gas so that it can stabilise. I have disconnected the air flow sensor because the cables connecting the air flow sensor are rubbing each other. I was advised to have all the cables replaced, but am afraid maybe that will be the end of my car. Please advise.

15 of 15 people found this helpful.
50

might want to look at cleaning your idle air speed control valve, if this gets stuck closed it will not idle right, plus it wont accelerate during low RPM's

5 of 5 people found this helpful.
70

Folks, I was having the similar problem in my C200 Kompressor about 8 months ago when I accelerate, the car takes time to pick-up speed. I was aked to change the accelerator unit which has a built in sensor. I did and about $700 /- later the problem was fixed. However, last week I started getting this similar problem again. I read somewhere that the MAF sensor could also be a cause for this proble. Last night I decided to give a few slight taps on the MAF unit with a rubber mullet (hammer) whilst having my son rev the engine slighty. This morning I found the car to be driving beautifully. I guess the MAF might need replacing soon but at least I was not holding up traffic in the fast lane on the highway until thuis problem reoccurs again.

7 of 7 people found this helpful.
100

I have a 1995 e320 with 80,000 miles on it. When I floor it 60mph, the rpm won't drop down and pick up again. Instead it will slowly go up 5-6 rpms and it won't change gears as it should. Other than that it drives fine. Should I change te trans fluid?

10 of 10 people found this helpful.
190

Question : as I put my car in drive and push on the gas , my car will make the sound as it should if it were actually moving , but doesn't at all even if I floor it . Then finally it will just jump and start driving normally . I have a 2003 Ford Explorer and yes my engine light is on . Even if I stop at a red light this will happen .Any info is appreciated . Thanks

19 of 19 people found this helpful.
10

I have the same exact problem what could it be it has the check engine light on so i took it to autozone they put the scanner and they told me it could be the accelerator sensor but other people are telling me that couldnt be it others are telling me tp help?

1 of 1 people found this helpful.
70

no smoke, no check engine light is o, my acura tl wont accelerate, it doesnt, then catches, what could it be?

7 of 7 people found this helpful.
60

Lets try this again. Its not the mas flow air sensor so get it put out of your heads. These cars have what they call "drive by wire"systems which means that the gas pedal is electronic and works the cars computer. Most Benz's would go into limp mode causing the car to take off slowly. Now if there is a misfire SOME benz will shake but alot of them you can't tell because the spark will compensate (most benz have 2 spark plugs per cylinder). Anyway back to the pedal. Because its electronic you most likely need to have the pedal reprogrammed with the software at the dealership. Hope this helps.

6 of 6 people found this helpful.
70

Mine is a BMW 1 series 2005 model it doesn't pickup speed it later does only to stall again going below 40 especially at steep hills and when I stop at robots.The pedal if released then it will pickup only for a while and it will gow slow again.Recently had to fix it while it overheated and leaked oil but those are fine now its an automatic,please help

4 of 4 people found this helpful.
60

I have a 2004 Chevy Blazer and when I hit the accelerator, it only goes 30 miles per hour. What could be the problem.

6 of 6 people found this helpful.
70

Just fixed mine after being diagnosed and was told its valvetronic but was sceptical about it.After seeking second opinion they told me it was a computer box and I went for it and it has been three weeks now and its perfect its like I'm driving a new car and on top of that its guaranteed for six months

3 of 3 people found this helpful.
30

Bought a ford escape 2004 staggering at low RPM not picking up speed, always good when pushing gas pedal down and getting over 2000rpm. Correlated problem came on when extremely cold, after a motor wash. Engine light on and intermittently blinking. Alarm! Needed winter 4x4 so couldn't have it checked. I bought most expensive 2 component gas cleaner and ran several tanks.--- NOW: Engine lights are off, no staggering. Suspect water in the gas crystallizing with dirt at -10 F in the winter plugging gas flow intermittently. Now weather warm and gas clean. All good. No mechanic. Just common sense. Costs 20 $ and nerves- patience.

3 of 3 people found this helpful.
40

Question: I was having the same problem as the original poster; I drive a 2005 Audi, Quattro, A4, 3.0 and while I know the make and model, I can't seem to figure out why when accelerating, the car hesitates, then after reaching a certain speed, either jerks or makes an obnoxiously loud revving sound that I feel under my feet through the floorboard. My dad test drove it, and pushed it so hard that it began to sound ever louder at any rate of acceleration. He pulled over to find that I needed oil. Pissed me off! What my question for you is, Where is that sound coming from? And is my car in danger of not returning to normal after his antics? It now makes that revving sound at any rate of acceleration; even after putting two quarts of (if my memory serves me correctly) Mobil w530 synthetic oil in it and placing injection fuel in the gas tank.

4 of 4 people found this helpful.
30

I have Saturn ion 2007 and it keeps shaking and When I press the gas pedal, it wont speed up right way after a while it will go up to 30mph but it wont go over 40mph. i change the senor and i also did the pedal reprogrammed. this did not help at all .......if anyone know please helppp

3 of 3 people found this helpful.
10

For some people still having this problem and if its not the tps or the MAF or AFM or anything else metioned, Then try checking your fuel pressure. I haven't seen this suggested yet so just check because it could be a weak or failing fuel pump. Everything else suggested is good too

1 of 1 people found this helpful.
20

I have a mitsubshi dion, feels like it is running out of gas, then picks up again, what could be the problem?

2 of 2 people found this helpful.
30

I have a 2012 chevy cruze accelerates real slow. I have changed the sparkplugs , put a new turbo intercooler bypass valve but still hasn't fixed the problem. Any ideas what else it could be???

220

I have C220 1996 ,having the same problem losing acceleration only goes up to 20 ,most when climbing towards the hill roads it frustrated no pulling later on the flat it picks up .Could it be the reason that i charged the Throttle , fuel pump and the unease cable or could it be something wrong with the engine ,please i need someone to help me

22 of 22 people found this helpful.
1,385

I have a automobile and the gas air mixture unit mounted in the valley of my V8 has flames coming out of it every so often and mid tail pipe explosions coming out of the tail pipe the motor will not run smoothly and to get it to tick over I give it full gas from the foot operated lever and the motor has no power I think the gas storage unit has water in it I am from the UK and have translated this into American so you can understand the correct terminology any help would be great thanks

1 of 1 people found this helpful.
60

I have a 2005 buick lacrosse that when I press the gas pedal it takes its delays in picking up speed I'm not sure with what is going on

6 of 6 people found this helpful.
30

I got my 2012 chevy cruze fixed. My turbo went out. We replaced it with a turbo I found on ebay from a salvage place. When we got it in it was working just fine then BAM that one blew but thank god they have a 90 day warranty on it so they sent me a new one but we discovered the line from the turbo to ? was stopped up so we replaced that then put the new turbo on & it's been good ever since.

1 of 1 people found this helpful.
30

Chansa18 mine was doing the same thing I replaced alot on it just to find out it was my turbo. I took it to a shop and let them put it on there machine & that's what they said it was & they were right. Good luck hope you get it fixed.

1 of 1 people found this helpful.
20

I have a MB A160. When the accelerator is pressed, absolutely nothing happens. It starts but concs out pretty quickly. The garage computer didn't flag up the problem! any ideas?

2 of 2 people found this helpful.
1,385

I would say its the acceleration lever faulty on your automobile

1 of 1 people found this helpful.
60

i have mercedes benz 320, it takes time before it picks up

6 of 6 people found this helpful.
70

If you check your throttle body you will have the answers

4 of 4 people found this helpful.
70

What it is your throttle body is messed up what happen is it put your car in Limp mode it will not go over 40 miles per hour

3 of 3 people found this helpful.

I have a 2004 Ford explorer it starts but won't accelerate so I pulled battery cables off nothing changed but if I tried starting again nothing happened so I pulled keys out put back In and bingo it accelerates and works fine not sure of problem

1,385

mans u got bare problems with ur malfunctioning automobile take it to your local shop and the technician should be able to diagnose the problem

10

I have a 99 Chevy Suburban I changed the spark plugs ,wires did a oil change. Just recently it will pick up speed slow very slowly it will not go over 40 mph ,and going uphill it will only go maybe 10 miles per hour its shifting fine but in order to pick up speed I have to let off the gas and press on it again not sure what the issue is I don't know if its catalytic converter that's clogged maybe my fuel filter any ideas?

1 of 1 people found this helpful.
10

My car have same situation. The car did not speed up when I press the gas pedal, and the check engine light on, when the light gas level on, but after I filled to full gas all gone (check engine and the car speed up )

1 of 1 people found this helpful.
20

My car is doing something Similar... It won't even up 4,000 RPMS while driving. I don't push my car that hard, but I know It feels like its not performing as much as it should. I did take to a auto place. we found out that when I floor it, the Mass Air Flow Sensor Flap isn't moving. Could this be similar?

2 of 2 people found this helpful.
1,385

has your automobile got a high mileage? and does it have regular oil changes?

30

i have a bmw E46 320i when i move from rest and accelerate with air con on engine fails and switches off, and the car stuggles to reach 200 km/h and can not go beyond that.

3 of 3 people found this helpful.
220

Can any one help me what could be the problem to my Benz car c220 w202 1996 model .The problem is that i noticed that 2 sparking plugs 2 and 3 are not firing of which my acceleration is very fool

can someone help me

anyone know anything about cadillacs

1,385

yes they are an American based car manufacturer. Set up in 1902, they where famed for big luxury cars like the Fleetwood sixty and the coupe deville. however in the 1980's everything changed and it all went downhill with cars like the 84' Cimarron and the 89' sedan deville. today they are trying to get back to the luxury cars of the 60's but its sad that they just can't do it.

3 of 3 people found this helpful.

Can some one help me I have a 1997 Honda civic Lx and sometimes when I try turning on it backfires and I have to press gas as soon as I do it sputters and takes a bit in which would seem like a clogged fuel pump and then finally stops backfiring and will actually wont turn off. After driving it will do the same thing and sometimes I have to put gas treatment and fill it up before it reaches about a quarter tank for it to turn on. I think it might be a fuel pump problem but not completely sure.

I have a 2009 nissan altima and my car does the exact same thing. When I am on the interstate and driving 70mph it feels as if im only driving about 50ph and thats me flooring the gas. It also picks back up after a while then slows down again please help?

40

Hi I have a 1995 Mercedes Benz s500 please can you help me to fix it it will run for a little bit it won't Drive good I press gas paddle and it won't drvie please help

2 of 2 people found this helpful.
40

Call me at 5093621779 or text thank you

40

It only goes RPM when you put it on drive

1,385

Check throttle cable

I have a 2003 Ford Escape. It runs good while idling but when you put it into gear and push on the gas it bogs down really bad and i can never get it above 15 mph. I can even barely push on gas pedal and it still bogs down. Can someone maybe help me with this problem

Hi all my c240 was shaking when i was accelerating and i was very stressed to all who have this problem please try balancing your tires and getting them checked before you touch the suspension i was happy to find out that my left tire was causing the Problem i nearly lost money as all the mechanics kept on guessing

20

What makes c220 benz dragging when driving. When going driving it reduces speed and pick up again .

2 of 2 people found this helpful.

Bmw 3 series speed not pick up

5

This happened to my daughters 2003 C240. First the alternator went out. We replaced it with another Valero from O'Reilly Auto Parts @ about $225. Then code P0123 popped up on the OBD II scanner, which is the Throttle Position Sensor on the accelerator pedal assembly. Replaced that with a unit from PartsGeek for about $125. Only took about 7 minutes to install. Test drove the car and it was still sluggish when pushing on the gas pedal hard. I let off the pedal and it would catch up a little, but then would almost stall when at a complete stop. I read where it may be the Mass Airflow Sensor. Luckily I already had some MAF sensor cleaner on hand. I unhooked the battery cable for about 40 minutes. Then took off the air filter cover and sprayed the MAF sensor a good bit. Put everything back together, and hooked the battery back up. Everything is running great now. The engine even seems to be more peppy than it did before. I hope the MAF sensor was only dirty and doesn't have to be replaced. As for now, a dirty MAF sensor was the culprit! If anything else changes, I will keep you all informed.

I have a C250 2012 model and when I put it on drive it doesn't move, I see no foce but slowly what cold be the possible cause

Your Answer

Add photo

Related Questions

C-Class

Looking for a Used C-Class in your area?

CarGurus has 26,582 nationwide C-Class listings starting at $2,000.

ZIP:

Search Mercedes-Benz C-Class Questions

Mercedes-Benz C-Class Experts

#1 Lorne Grandison
Lorne Grandison
Reputation 4,790
#2 PPC123
PPC123
Reputation 3,340
#3 dandyoun
dandyoun
Reputation 2,420
View All

Related Models For Sale

Used Mercedes-Benz E-Class
418 Great Deals out of 19,904 listings starting at $699
Used BMW 3 Series
973 Great Deals out of 31,729 listings starting at $1,000
Used Mercedes-Benz S-Class
171 Great Deals out of 6,479 listings starting at $2,700
Used BMW 5 Series
460 Great Deals out of 15,985 listings starting at $1,700
Used Audi A4
227 Great Deals out of 10,877 listings starting at $1,899
Used BMW M3
45 Great Deals out of 1,517 listings starting at $5,800
Used Ford Mustang
472 Great Deals out of 45,735 listings starting at $1,999
Used Chevrolet Camaro
226 Great Deals out of 30,943 listings starting at $1,217
Used Honda Accord
813 Great Deals out of 84,287 listings starting at $1,050

Used Cars For Sale

2017 Mercedes-Benz C-Class For Sale
22 Great Deals out of 13,122 listings starting at $31,950
2016 Mercedes-Benz C-Class For Sale
61 Great Deals out of 1,957 listings starting at $24,755
2015 Mercedes-Benz C-Class For Sale
44 Great Deals out of 1,286 listings starting at $20,915
2014 Mercedes-Benz C-Class For Sale
65 Great Deals out of 2,358 listings starting at $13,980
2013 Mercedes-Benz C-Class For Sale
55 Great Deals out of 1,738 listings starting at $12,190

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.