i have a 2000 blazer ls.....we filled with new transmission fluid and still wont move......runs and idles fine....but wont engage....is tranny blown??thanks

Asked by Dec 31, 2013 at 01:34 PM about the 2000 Chevrolet Blazer 4 Door LS 4WD

Question type: Maintenance & Repair

1 Answer

246,575

I always like to change the fluid before I rule out other possibilities. Do you think it's a linkage issue? It very well could be internal to the trans. Have it towed to a garage to get an estimate. Your probably looking at a rebuild . So do you want to spend anymore money on it?

Your Answer

Add photo

Related Questions

Search Chevrolet Blazer Questions

Chevrolet Blazer Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,010
#2 yetilikesbeer
yetilikesbeer
Reputation 1,320
#3 Rowefast
Rowefast
Reputation 1,030
View All

Related Models For Sale

Used Chevrolet Tahoe
582 Great Deals out of 33,058 listings starting at $1,500
Used Chevrolet S-10
6 Great Deals out of 1,332 listings starting at $1,999
Used Chevrolet Silverado 1500
1,950 Great Deals out of 183,196 listings starting at $1,495
Used GMC Jimmy
287 listings
Used Ford Explorer
912 Great Deals out of 64,625 listings starting at $799
Used Jeep Grand Cherokee
1,081 Great Deals out of 73,543 listings starting at $1,200
Used Ford F-150
2,150 Great Deals out of 193,915 listings starting at $290
Used Chevrolet C/K 1500
4 Great Deals out of 868 listings starting at $1,950
Used Toyota 4Runner
234 Great Deals out of 19,524 listings starting at $1,500
Used Chevrolet Suburban
272 Great Deals out of 19,284 listings starting at $1,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.