i have a 2000 blazer ls.....we filled with new transmission fluid and still wont move......runs and idles fine....but wont engage....is tranny blown??thanks

Asked by Dec 31, 2013 at 01:34 PM about the 2000 Chevrolet Blazer 4 Door LS 4WD

Question type: Maintenance & Repair

1 Answer

223,595

I always like to change the fluid before I rule out other possibilities. Do you think it's a linkage issue? It very well could be internal to the trans. Have it towed to a garage to get an estimate. Your probably looking at a rebuild . So do you want to spend anymore money on it?

Your Answer

Add photo

Search Chevrolet Blazer Questions

Chevrolet Blazer Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 1,890
#2 yetilikesbeer
yetilikesbeer
Reputation 1,190
#3 Rowefast
Rowefast
Reputation 820
View All

Related Models For Sale

Used Chevrolet Tahoe
775 Great Deals out of 28,448 listings starting at $1,500
Used Chevrolet S-10
10 Great Deals out of 1,655 listings starting at $2,450
Used Chevrolet Silverado 1500
2,287 Great Deals out of 155,182 listings starting at $1,395
Used GMC Jimmy
286 listings starting at $1,995
Used Jeep Grand Cherokee
844 Great Deals out of 68,670 listings starting at $864
Used Ford Explorer
935 Great Deals out of 73,729 listings starting at $750
Used Chevrolet Camaro
282 Great Deals out of 38,308 listings starting at $1,250
Used Ford F-150
2,693 Great Deals out of 211,512 listings starting at $1,000
Used Chevrolet C/K 1500
1,050 listings starting at $2,000
Used Jeep Cherokee
347 Great Deals out of 55,333 listings starting at $2,295
Used Chevrolet Impala
795 Great Deals out of 34,381 listings starting at $799
Used GMC Yukon
516 Great Deals out of 17,124 listings starting at $1,799