2000 Blazer 4wd not working

Asked by Jun 10, 2017 at 05:25 PM about the 2000 Chevrolet Blazer 2 Door LS 4WD

Question type: Maintenance & Repair

I bought a 2000 4wd Blazer a couple months ago.
It has the 4.3 vortec engine and push button 4wd.
When I put it in neutral and press "auto 4wd" the
light just flashes endlessly. When I press 4Hi, the
light doesn't come on at all, but when I press 4Lo
you can here the "clank" of the 4 lo, and the light
stays on constantly for 4lo, but it's not pulling. I'm
not very educated with 4wd vehicles as this is only
the 2nd one I've owned and never had any issues
to fix with the first one. Could someone please
point me in the right path towards making my 4wd
work?

No answers yet

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,030
  • #2
    yetilikesbeer
    Reputation
    1,330
  • #3
    Rowefast
    Reputation
    1,030
View All

Related Models For Sale

Used Chevrolet Tahoe
643 Great Deals out of 36,956 listings starting at $1,800
Used Chevrolet S-10
7 Great Deals out of 1,283 listings starting at $1,800
Used Chevrolet Silverado 1500
2,134 Great Deals out of 183,037 listings starting at $1,898
Used GMC Jimmy
3 Great Deals out of 246 listings starting at $1,900
Used Chevrolet Camaro
420 Great Deals out of 31,911 listings starting at $2,395
Used Ford Explorer
798 Great Deals out of 63,365 listings starting at $1,495
Used Jeep Grand Cherokee
890 Great Deals out of 71,728 listings starting at $995
Used Chevrolet C/K 1500
873 listings starting at $3,195
Used Ford F-150
2,235 Great Deals out of 183,025 listings starting at $1,500
Used Jeep Cherokee
402 Great Deals out of 41,245 listings starting at $1,800
Used Jeep Wrangler
281 Great Deals out of 15,911 listings starting at $2,997

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.