im not getting feul to the cylinders after fuell tank pump and sending unit was replaced i have and fuel pressure is good but nothing is makeing it past the the injectors

5

Asked by Dec 04, 2010 at 03:06 PM about the 1994 Chevrolet S-10 Blazer 4 Dr Tahoe LT 4WD SUV

Question type: Maintenance & Repair

1 Answer

5

you could have a bad fuel rail or the injectors could be clogged.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,510
#2 Cody Doud
Cody Doud
Reputation 620
#3 emtfirefighter77
emtfirefighter77
Reputation 340
View All

Related Models For Sale

Used Chevrolet S-10
8 Great Deals out of 1,349 listings starting at $1,899
Used Chevrolet Blazer
1,175 listings starting at $1,495
Used Chevrolet Tahoe
598 Great Deals out of 33,195 listings starting at $1,375
Used Ford F-150
2,089 Great Deals out of 191,500 listings starting at $290
Used Ford Mustang
689 Great Deals out of 44,320 listings starting at $1,500
Used Toyota 4Runner
227 Great Deals out of 19,339 listings starting at $2,300
Used Jeep Cherokee
350 Great Deals out of 40,143 listings starting at $1,500
Used Chevrolet Monte Carlo
12 Great Deals out of 1,428 listings starting at $2,400
Used Chevrolet Camaro
375 Great Deals out of 31,274 listings starting at $2,500
Used Chevrolet Impala
553 Great Deals out of 35,458 listings starting at $899
Used Dodge Ram 1500
405 Great Deals out of 10,893 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.