Oil coolers problems

Asked by May 07, 2009 at 02:59 PM about the 1993 Chevrolet S-10 Blazer 4 Dr Tahoe SUV

Question type: Maintenance & Repair

I have a 1993 S10 Tahoe Blazer, 4.3L V6, 4dr 2wd, automatic transmission. it was equiped with a factory oil cooler. the problem is the previous owners stripped the threads to both in port and out port of the cooler adapter where the hoses screw in. and the hose leaks. ive looked everywhere for parts and solutions and all i do is run into dead ends. any suggestions?

1 Answer

35

Take a tap and die set to the threads, and make sure you flush it well. Hylomar also works pretty well. Just don't use any silicone-based sealant, as the oil will dissolve it.

Your Answer

Chevrolet S-10 Blazer Experts

  • #1
    carGrrl
    Reputation
    1,550
  • #2
    Cody Doud
    Reputation
    660
  • #3
    emtfirefighter77
    Reputation
    390
View All

Related Models For Sale

Used Chevrolet S-10
15 Great Deals out of 1,255 listings starting at $1,600
Used Chevrolet Blazer
5 Great Deals out of 1,075 listings starting at $950
Used Ford Ranger
153 Great Deals out of 5,399 listings starting at $800
Used Ford F-150
2,512 Great Deals out of 193,861 listings starting at $799
Used Chevrolet Suburban
389 Great Deals out of 22,715 listings starting at $1,999
Used Chevrolet C/K 1500
858 listings starting at $2,000
Used GMC Sonoma
468 listings starting at $2,100
Used Chevrolet Impala
559 Great Deals out of 35,105 listings starting at $900
Used Chevrolet Camaro
407 Great Deals out of 30,592 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.