Oil coolers problems

Asked by May 07, 2009 at 02:59 PM about the 1993 Chevrolet S-10 Blazer 4 Dr Tahoe SUV

Question type: Maintenance & Repair

I have a 1993 S10 Tahoe Blazer, 4.3L V6, 4dr 2wd, automatic transmission. it was equiped with a factory oil cooler. the problem is the previous owners stripped the threads to both in port and out port of the cooler adapter where the hoses screw in. and the hose leaks. ive looked everywhere for parts and solutions and all i do is run into dead ends. any suggestions?

1 Answer

35

Take a tap and die set to the threads, and make sure you flush it well. Hylomar also works pretty well. Just don't use any silicone-based sealant, as the oil will dissolve it.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,440
#2 Cody Doud
Cody Doud
Reputation 610
#3 emtfirefighter77
emtfirefighter77
Reputation 330
View All

Related Models For Sale

Used Chevrolet S-10
10 Great Deals out of 1,345 listings starting at $1,395
Used Chevrolet Blazer
4 Great Deals out of 1,167 listings starting at $1,255
Used Chevrolet Camaro
226 Great Deals out of 30,943 listings starting at $1,217
Used GMC Jimmy
257 listings starting at $2,495
Used Dodge Ram 1500
453 Great Deals out of 11,152 listings starting at $700
Used Chevrolet Impala
521 Great Deals out of 31,726 listings starting at $1,450
Used Jeep Cherokee
460 Great Deals out of 52,444 listings starting at $1,800
Used GMC Sonoma
5 Great Deals out of 469 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.