fuel pump not working

Asked by Jul 20, 2015 at 10:38 PM about the 1993 Chevrolet S-10 Blazer 4 Dr STD SUV

Question type: Maintenance & Repair

I have 12 volts running to the plug that connects to the fuel pump but the pump doesnt
run. Any ideas?

3 Answers

21,660

Either a bad connector to fuel pump or a bad fuel pump.

30

Reverse polarity the fuel pump will usually break free.then wire it back up.should b good to go.

30,045

also..if you have not fixed it by now..you can just get the part you need and not the whole assembly.....

Your Answer

S-10 Blazer

Looking for a Used S-10 Blazer in your area?

CarGurus has 24 nationwide S-10 Blazer listings and the tools to find you a great deal.

ZIP:

Chevrolet S-10 Blazer Experts

  • #1
    carGrrl
    Reputation
    1,780
  • #2
    Cody Doud
    Reputation
    730
  • #3
    emtfirefighter77
    Reputation
    550
View All

Related Models For Sale

Used Chevrolet Blazer
4 Great Deals out of 714 listings starting at $900
Used Chevrolet S-10
10 Great Deals out of 957 listings starting at $950
Used Ford F-150
2,344 Great Deals out of 215,477 listings starting at $1,300
Used Chevrolet C/K 1500
727 listings starting at $2,499
Used Toyota 4Runner
281 Great Deals out of 32,848 listings starting at $950
Used Chevrolet Camaro
224 Great Deals out of 28,922 listings starting at $3,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.