No power to the fuse block on my s10

Asked by Oct 18, 2015 at 01:42 PM about the 2002 Chevrolet S-10 4 Dr LS 4WD Crew Cab SB

Question type: Maintenance & Repair

Wen the battery is disconnected  all the
fuses activate my test light as soon as I
connect the battery the big fuses and some
others don't activate my fuse light  What
can I do

1 Answer

79,095

Check the battery cable connections at both ends. Make sure everything is clean and tight. Also check the wiring down by the starter. A catastrophic failure, such as this, is going to be battery related. HTH. -Jim

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,800
  • #2
    John Saffrahn
    Reputation
    1,110
  • #3
    Trebor66
    Reputation
    1,090
View All

Related Models For Sale

Used Chevrolet Silverado 1500
1,755 Great Deals out of 153,126 listings starting at $1,000
Used Ford Ranger
121 Great Deals out of 4,350 listings starting at $1,500
Used Toyota Tacoma
405 Great Deals out of 47,516 listings starting at $2,994
Used GMC Sonoma
287 listings starting at $2,150
Used Ford F-150
2,231 Great Deals out of 209,289 listings starting at $1,300
Used Nissan Frontier
282 Great Deals out of 23,227 listings starting at $1,295
Used Dodge Dakota
80 Great Deals out of 3,053 listings starting at $1,495
Used Chevrolet Blazer
697 listings starting at $895
Used GMC Sierra 1500
698 Great Deals out of 60,847 listings starting at $1,395
Used Dodge Ram 1500
320 Great Deals out of 9,389 listings starting at $1,500
Used Chevrolet Camaro
229 Great Deals out of 27,307 listings starting at $2,800
Used Ford Mustang
273 Great Deals out of 37,582 listings starting at $1,350

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.