I have a 2001 S10 2.2 5 speed that starts and dies immediately. We disconnected the line at the filter and its got pressure. Any suggestions? I love this trick and would like to fix it asap.

Asked by Apr 13, 2015 at 12:16 PM about the 2001 Chevrolet S-10 2 Dr STD Standard Cab SB

Question type: Maintenance & Repair

1 Answer

7,245

Possible bad maf sensor, have it scanned.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,240
#2 John Saffrahn
John Saffrahn
Reputation 970
#3 Trebor66
Trebor66
Reputation 950
View All

Related Models For Sale

Used Ford Ranger
192 Great Deals out of 5,979 listings starting at $1,299
Used Chevrolet Silverado 1500
1,741 Great Deals out of 167,619 listings starting at $1,800
Used GMC Sonoma
8 Great Deals out of 489 listings starting at $2,995
Used Toyota Tacoma
506 Great Deals out of 38,899 listings starting at $2,900
Used Ford F-150
2,215 Great Deals out of 208,754 listings starting at $1,499
Used Dodge Dakota
110 Great Deals out of 3,828 listings starting at $1,199
Used Chevrolet Blazer
1,148 listings starting at $1,299
Used Nissan Frontier
348 Great Deals out of 26,729 listings starting at $2,200
Used Dodge Ram 1500
441 Great Deals out of 11,299 listings starting at $1,000
Used GMC Sierra 1500
820 Great Deals out of 66,215 listings starting at $1,995
Used Chevrolet Camaro
156 Great Deals out of 32,706 listings starting at $1,995
Used Ford Mustang
364 Great Deals out of 46,842 listings starting at $1,999