I have a 2001 S10 2.2 5 speed that starts and dies immediately. We disconnected the line at the filter and its got pressure. Any suggestions? I love this trick and would like to fix it asap.

Asked by Apr 13, 2015 at 12:16 PM about the 2001 Chevrolet S-10 2 Dr STD Standard Cab SB

Question type: Maintenance & Repair

1 Answer

7,595

Possible bad maf sensor, have it scanned.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,360
#2 John Saffrahn
John Saffrahn
Reputation 1,000
#3 Trebor66
Trebor66
Reputation 990
View All

Related Models For Sale

Used Ford Ranger
178 Great Deals out of 5,613 listings starting at $1,200
Used Chevrolet Silverado 1500
1,920 Great Deals out of 181,823 listings starting at $1,595
Used GMC Sonoma
5 Great Deals out of 435 listings starting at $1,488
Used Toyota Tacoma
517 Great Deals out of 42,739 listings starting at $1,995
Used Ford F-150
2,140 Great Deals out of 195,105 listings starting at $290
Used Dodge Dakota
127 Great Deals out of 3,791 listings starting at $1,350
Used Nissan Frontier
326 Great Deals out of 21,037 listings starting at $1,250
Used GMC Sierra 1500
783 Great Deals out of 68,500 listings starting at $1,800
Used Chevrolet Blazer
1,179 listings starting at $1,495
Used Dodge Ram 1500
390 Great Deals out of 10,792 listings starting at $1,000
Used Chevrolet Camaro
350 Great Deals out of 31,219 listings starting at $2,500

Used Cars For Sale

2004 Chevrolet S-10 For Sale
53 listings starting at $2,695
2003 Chevrolet S-10 For Sale
311 listings starting at $1,999
2002 Chevrolet S-10 For Sale
202 listings starting at $2,880

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.