2001 chevy s10 fuel pump runs but no pressure at pump of filter ?

Asked by Feb 25, 2015 at 11:30 PM about the 2001 Chevrolet S-10 2 Dr LS 4WD Extended Cab SB

Question type: Maintenance & Repair

1 Answer

645

your pump is running but not pumping. you need a new one. or the line came off of the pump. but since you have to go through the trouble taking the tank off you might as well change the pump so you don't have to worry about it.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,360
#2 John Saffrahn
John Saffrahn
Reputation 1,000
#3 Trebor66
Trebor66
Reputation 990
View All

Related Models For Sale

Used Ford Ranger
183 Great Deals out of 5,624 listings starting at $900
Used Chevrolet Silverado 1500
1,976 Great Deals out of 183,616 listings starting at $1,595
Used GMC Sonoma
4 Great Deals out of 424 listings starting at $1,988
Used Toyota Tacoma
570 Great Deals out of 42,600 listings starting at $1,995
Used Ford F-150
2,133 Great Deals out of 191,041 listings starting at $290
Used Dodge Dakota
127 Great Deals out of 3,786 listings starting at $1,500
Used Nissan Frontier
337 Great Deals out of 20,817 listings starting at $1,250
Used Chevrolet Blazer
3 Great Deals out of 1,182 listings starting at $1,495
Used GMC Sierra 1500
807 Great Deals out of 68,325 listings starting at $1,300
Used Dodge Ram 1500
410 Great Deals out of 10,894 listings starting at $1,000
Used Chevrolet Camaro
367 Great Deals out of 31,399 listings starting at $2,400
Used Toyota Tundra
469 Great Deals out of 34,460 listings starting at $1,950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.