2001 chevy s10 fuel pump runs but no pressure at pump of filter ?

Asked by Feb 25, 2015 at 11:30 PM about the 2001 Chevrolet S-10 LS Extended Cab 4WD

Question type: Maintenance & Repair

1 Answer

725

your pump is running but not pumping. you need a new one. or the line came off of the pump. but since you have to go through the trouble taking the tank off you might as well change the pump so you don't have to worry about it.

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,830
  • #2
    John Saffrahn
    Reputation
    1,120
  • #3
    Trebor66
    Reputation
    1,110
View All

Related Models For Sale

Used Ford Ranger
102 Great Deals out of 4,205 listings starting at $1,700
Used Chevrolet Silverado 1500
1,726 Great Deals out of 154,936 listings starting at $1,700
Used Toyota Tacoma
421 Great Deals out of 49,181 listings starting at $2,400
Used GMC Sonoma
3 Great Deals out of 292 listings starting at $1,500
Used Ford F-150
2,281 Great Deals out of 188,281 listings starting at $1,300
Used Chevrolet Blazer
733 listings starting at $900
Used Dodge Dakota
86 Great Deals out of 3,041 listings starting at $1,700
Used Nissan Frontier
313 Great Deals out of 22,124 listings starting at $1,295
Used GMC Sierra 1500
777 Great Deals out of 60,201 listings starting at $1,500
Used Dodge Ram 1500
335 Great Deals out of 9,325 listings starting at $1,500
Used Chevrolet Camaro
233 Great Deals out of 26,932 listings starting at $4,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.