I have a 2001 s-10 with a 4.3, when i put the truck in gear, all gears work, but after it warms up I lose all gears

Asked by Feb 24, 2017 at 10:49 PM about the 2001 Chevrolet S-10 4 Dr LS 4WD Crew Cab SB

Question type: Maintenance & Repair

1 Answer

25,855

How is the fluid level? If it's too full, the fluid may become aerated by rotating parts or by an internal leak and cause loss of pressure. Is there any noise, especially whining, from tranny? Your problem sounds like a loss of pressure, which can be caused by a few things. Look into getting a pressure test done.

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,370
  • #2
    Trebor66
    Reputation
    1,030
  • #3
    John Saffrahn
    Reputation
    1,000
View All

Related Models For Sale

Used Ford Ranger
169 Great Deals out of 5,524 listings starting at $1,000
Used Chevrolet Silverado 1500
2,132 Great Deals out of 181,503 listings starting at $1,898
Used GMC Sonoma
5 Great Deals out of 428 listings starting at $1,900
Used Toyota Tacoma
562 Great Deals out of 41,710 listings starting at $2,999
Used Ford F-150
2,117 Great Deals out of 181,537 listings starting at $1,000
Used Dodge Dakota
123 Great Deals out of 3,642 listings starting at $1,650
Used Chevrolet Blazer
3 Great Deals out of 1,149 listings starting at $950
Used Nissan Frontier
321 Great Deals out of 20,815 listings starting at $1,995
Used GMC Sierra 1500
790 Great Deals out of 67,767 listings starting at $1,350
Used Dodge Ram 1500
401 Great Deals out of 10,657 listings starting at $1,500
Used Chevrolet Camaro
414 Great Deals out of 31,676 listings starting at $2,395
Used Ford Mustang
741 Great Deals out of 42,181 listings starting at $1,300

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.