my 2000 extreme runs good when its not rainin but if it rans it wont start and it aint got the spider injectors wat it coud it be

Asked by Nov 26, 2013 at 08:25 PM about the 2000 Chevrolet S-10 2 Dr LS Xtreme Standard Cab SB

Question type: Maintenance & Repair

2 Answers

its also a 4.3 v6

115

this happened to me when my plug wires were bad. We had one really bad blizzard and it didn't start. I changed them and it ran fine thereafter

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,300
#2 John Saffrahn
John Saffrahn
Reputation 970
#3 Trebor66
Trebor66
Reputation 960
View All

Related Models For Sale

Used Ford Ranger
197 Great Deals out of 5,805 listings starting at $1,650
Used Chevrolet Silverado 1500
1,717 Great Deals out of 175,749 listings starting at $1,250
Used GMC Sonoma
5 Great Deals out of 469 listings starting at $2,500
Used Toyota Tacoma
541 Great Deals out of 40,814 listings starting at $2,495
Used Ford F-150
2,194 Great Deals out of 206,316 listings starting at $1,499
Used Dodge Dakota
106 Great Deals out of 3,781 listings starting at $1,680
Used Nissan Frontier
305 Great Deals out of 25,149 listings starting at $1,995
Used GMC Sierra 1500
822 Great Deals out of 68,199 listings starting at $2,484
Used Chevrolet Blazer
4 Great Deals out of 1,167 listings starting at $1,255
Used Dodge Ram 1500
455 Great Deals out of 11,152 listings starting at $700
Used Chevrolet C/K 1500
892 listings starting at $2,500
Used Chevrolet Camaro
225 Great Deals out of 30,943 listings starting at $1,217
Used Ford Mustang
476 Great Deals out of 45,735 listings starting at $1,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.