my 2000 extreme runs good when its not rainin but if it rans it wont start and it aint got the spider injectors wat it coud it be

Asked by Nov 26, 2013 at 08:25 PM about the 2000 Chevrolet S-10 2 Dr LS Xtreme Standard Cab SB

Question type: Maintenance & Repair

2 Answers

its also a 4.3 v6

95

this happened to me when my plug wires were bad. We had one really bad blizzard and it didn't start. I changed them and it ran fine thereafter

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,240
#2 Trebor66
Trebor66
Reputation 950
#3 John Saffrahn
John Saffrahn
Reputation 940
View All

Related Models For Sale

Used Ford Ranger
177 Great Deals out of 6,201 listings starting at $1,300
Used Chevrolet Silverado 1500
1,952 Great Deals out of 159,903 listings starting at $1,995
Used GMC Sonoma
5 Great Deals out of 475 listings starting at $2,499
Used Toyota Tacoma
531 Great Deals out of 37,484 listings starting at $2,950
Used Ford F-150
2,403 Great Deals out of 209,424 listings starting at $895
Used Dodge Dakota
101 Great Deals out of 3,890 listings starting at $1,500
Used Chevrolet Blazer
1,135 listings starting at $1,995
Used Nissan Frontier
375 Great Deals out of 25,884 listings starting at $890
Used GMC Sierra 1500
876 Great Deals out of 64,409 listings starting at $1,500
Used Dodge Ram 1500
427 Great Deals out of 11,401 listings starting at $700
Used Chevrolet C/K 1500
880 listings starting at $2,500
Used Chevrolet Camaro
132 Great Deals out of 35,283 listings starting at $1,995
Used Chevrolet Tahoe
600 Great Deals out of 27,562 listings starting at $600

Used Cars For Sale