have a lean condition on both banks 1&2

Asked by Mar 14, 2017 at 05:49 PM about the 2000 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

i have replaced air and fuel filters truck starts and runs fine when engine is hot
but when its cold its very hard to start

2 Answers

73,155

If you have a lean condition, then check for vacuum leaks, especially along the intake manifold.

1 of 1 people found this helpful.

thank u i will try that before i go to the oxygem sensors

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,370
  • #2
    Trebor66
    Reputation
    1,030
  • #3
    John Saffrahn
    Reputation
    1,000
View All

Related Models For Sale

Used Ford Ranger
166 Great Deals out of 5,528 listings starting at $1,000
Used Chevrolet Silverado 1500
2,164 Great Deals out of 181,160 listings starting at $1,900
Used GMC Sonoma
6 Great Deals out of 446 listings starting at $1,900
Used Toyota Tacoma
580 Great Deals out of 41,994 listings starting at $2,995
Used Ford F-150
2,175 Great Deals out of 181,305 listings starting at $1,000
Used Dodge Dakota
116 Great Deals out of 3,651 listings starting at $1,650
Used Chevrolet Blazer
3 Great Deals out of 1,145 listings starting at $950
Used Nissan Frontier
327 Great Deals out of 21,017 listings starting at $1,995
Used GMC Sierra 1500
799 Great Deals out of 67,480 listings starting at $1,350
Used Dodge Ram 1500
399 Great Deals out of 10,733 listings starting at $1,500
Used Chevrolet C/K 1500
895 listings starting at $3,195
Used Chevrolet Camaro
434 Great Deals out of 31,755 listings starting at $2,395
Used Toyota Tundra
446 Great Deals out of 33,541 listings starting at $1,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.