have a lean condition on both banks 1&2

Asked by Mar 14, 2017 at 05:49 PM about the 2000 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

i have replaced air and fuel filters truck starts and runs fine when engine is hot
but when its cold its very hard to start

2 Answers

79,015

If you have a lean condition, then check for vacuum leaks, especially along the intake manifold.

1 of 1 people found this helpful.

thank u i will try that before i go to the oxygem sensors

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,650
  • #2
    John Saffrahn
    Reputation
    1,090
  • #3
    Trebor66
    Reputation
    1,070
View All

Related Models For Sale

Used Chevrolet Silverado 1500
2,684 Great Deals out of 157,095 listings starting at $1,000
Used Ford Ranger
125 Great Deals out of 5,019 listings starting at $1,299
Used Toyota Tacoma
550 Great Deals out of 41,421 listings starting at $2,500
Used GMC Sonoma
4 Great Deals out of 366 listings starting at $2,150
Used Ford F-150
3,046 Great Deals out of 230,459 listings starting at $1,300
Used GMC Sierra 1500
1,120 Great Deals out of 61,759 listings starting at $1,295
Used Dodge Dakota
82 Great Deals out of 3,459 listings starting at $1,475
Used Nissan Frontier
438 Great Deals out of 25,199 listings starting at $1,400
Used Chevrolet Blazer
6 Great Deals out of 846 listings starting at $950
Used Dodge Ram 1500
324 Great Deals out of 10,737 listings starting at $1,988
Used Chevrolet Camaro
398 Great Deals out of 31,479 listings starting at $3,495
Used Ford Explorer Sport Trac
54 Great Deals out of 1,779 listings starting at $1,800
Used Chevrolet C/K 1500
829 listings starting at $2,600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.