My 2000 Chevy s10 is making my radio have static but only when the truck is running. If you just turn the key so the battery is on, there is no static. I do have an after market radio but I put my stock radio back in and the same issue occurs. I have tried many things but no luck. I would appreciate any advice possible.

Asked by Oct 02, 2016 at 08:16 PM about the 2000 Chevrolet S-10 2 Dr LS Extended Cab Stepside SB

Question type: Car Customization

No answers yet

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,050
#2 John Saffrahn
John Saffrahn
Reputation 890
#3 Trebor66
Trebor66
Reputation 880
View All

Related Models For Sale

Used Ford Ranger
227 Great Deals out of 6,966 listings starting at $1,500
Used Chevrolet Silverado 1500
2,629 Great Deals out of 148,535 listings starting at $1,800
Used GMC Sonoma
11 Great Deals out of 489 listings starting at $1,500
Used Ford F-150
3,389 Great Deals out of 203,566 listings starting at $1,273
Used Toyota Tacoma
773 Great Deals out of 33,032 listings starting at $1,900
Used Dodge Dakota
117 Great Deals out of 4,351 listings starting at $995
Used Chevrolet Blazer
1,364 listings starting at $1,295
Used GMC Sierra 1500
1,156 Great Deals out of 57,801 listings starting at $995
Used Nissan Frontier
425 Great Deals out of 21,861 listings starting at $1,995
Used Dodge Ram 1500
568 Great Deals out of 12,973 listings starting at $1,200
Used Chevrolet C/K 1500
1,055 listings starting at $1,999
Used Chevrolet Camaro
646 Great Deals out of 39,146 listings starting at $2,995
Used Chevrolet Tahoe
1,068 Great Deals out of 32,280 listings starting at $1,495