I have a loud humm for about 30 seconds when the truck is started

Asked by Mar 18, 2016 at 12:52 PM about the 1999 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: General

When I start my 1999 S10 there is what looks like a pump that hums for about
30 second that is located below the radiator on the passenger side what is
this?

1 Answer

It was the secondary smog pump

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,340
#2 John Saffrahn
John Saffrahn
Reputation 990
#2 Trebor66
Trebor66
Reputation 990
View All

Related Models For Sale

Used Ford Ranger
176 Great Deals out of 5,675 listings starting at $950
Used Chevrolet Silverado 1500
1,777 Great Deals out of 181,195 listings starting at $250
Used Toyota Tacoma
473 Great Deals out of 41,586 listings starting at $1,995
Used Ford F-150
2,064 Great Deals out of 207,332 listings starting at $1,499
Used GMC Sonoma
5 Great Deals out of 453 listings starting at $2,798
Used Dodge Dakota
137 Great Deals out of 3,795 listings starting at $1,495
Used Nissan Frontier
291 Great Deals out of 23,778 listings starting at $1,995
Used Dodge Ram 1500
413 Great Deals out of 10,833 listings starting at $1,400
Used Chevrolet Blazer
3 Great Deals out of 1,188 listings starting at $1,820
Used GMC Sierra 1500
762 Great Deals out of 69,121 listings starting at $1,850
Used Chevrolet C/K 1500
861 listings starting at $3,290
Used Chevrolet Camaro
242 Great Deals out of 31,193 listings starting at $369
Used Toyota Tundra
437 Great Deals out of 34,674 listings starting at $2,990

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.